+ [ David Kalnischkies ]
+ * apt-pkg/packagemanager.cc:
+ - better debug output for ImmediateAdd with depth and why
+ - improve the message shown for failing immediate configuration
+ * doc/guide.it.sgml: moved to doc/it/guide.it.sgml
+ * doc/po4a.conf: activate translation of guide.sgml and offline.sgml
+ * doc/apt.conf.5.xml:
+ - provide a few more details about APT::Immediate-Configure
+ * doc/sources.list.5.xml:
+ - add note about additional apt-transport-methods
+ * doc/apt-mark.8.xml:
+ - correct showauto synopsis, thanks Andrew Schulman (Closes: #551440)
+ * cmdline/apt-get.cc:
+ - source should displays his final pkg pick (Closes: #249383, #550952)
+ - source doesn't need the complete version for match (Closes: #245250)
+ - source ignores versions/releases if not available (Closes: #377424)
+ - only warn if (free) space overflows (Closes: #522238)
+ - add --debian-only as alias for --diff-only
+ * methods/connect.cc:
+ - display also strerror of "wicked" getaddrinfo errors
+ * buildlib/configure.mak, buildlib/config.{sub,guess}:
+ - remove (outdated) config.{sub,guess} and use the ones provided
+ by the new added build-dependency autotools-dev instead
+ * configure.in, buildlib/{xml,yodl,sgml}_manpage.mak:
+ - remove the now obsolete manpage buildsystems
+ * doc/{pl,pt_BR,es,it}/*.{sgml,xml}:
+ - convert all remaining translation to the po4a system
+ * debian/control:
+ - drop build-dependency on docbook-utils and xmlto
+ - add build-dependency on autotools-dev
+ - bump policy to 3.8.3 as we have no outdated manpages anymore
+ * debian/NEWS:
+ - fix a typo in 0.7.24: Allready -> Already (Closes: #557674)
+ * cmdline/apt-mark:
+ - print an error if a new state file can't be created,
+ thanks Carl Chenet! (Closes: #521289)
+ - print an error and exit if python-apt is not installed,
+ thanks Carl Chenet! (Closes: #521284)
+ * ftparchive/writer.{cc,h}:
+ - add APT::FTPArchive::LongDescription to be able to disable them
+ * apt-pkg/deb/debsrcrecords.cc:
+ - use "diff" filetype for .debian.tar.* files (Closes: #554898)
+ * methods/rred.cc:
+ - rewrite to be able to handle even big patch files
+ - adopt optional mmap+iovec patch from Morten Hustveit
+ (Closes: #463354) which should speed up a bit. Thanks!
+
+ [ Chris Leick ]
+ * doc/ various manpages:
+ - correct various errors, typos and oddities (Closes: #552535)
+ * doc/apt-secure.8.xml:
+ - replace literal with emphasis tags in Archive configuration
+
+ [ Eugene V. Lyubimkin ]
+ * apt-pkg/contib/strutl.h
+ - Avoid extra inner copy in APT_MKSTRCMP and APT_MKSTRCMP2.
+ * build infrastructure:
+ - Bumped libapt version, excluded eglibc from SONAME. (Closes: #448249)
+
+ [ Julian Andres Klode ]
+ * doc/apt.conf.5.xml:
+ - Deprecate unquoted values, string concatenation and explain what should
+ not be written inside a value (quotes,backslash).
+ - Restrict option names to alphanumerical characters and "/-:._+".
+ - Deprecate #include, we have apt.conf.d nowadays which should be
+ sufficient.
+ * ftparchive/apt-ftparchive.cc:
+ - Call setlocale() so translations are actually used.
+ * debian/apt.conf.autoremove:
+ - Add kfreebsd-image-* to the list (Closes: #558803)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 10 Dec 2009 22:02:38 +0100
+
+apt (0.7.24) unstable; urgency=low
+
+ [ Nicolas François ]
+ * Cleaned up the first patch draft from KURASAWA Nozomu to finally
+ get po4a support for translating the man pages.
+ Many thanks to both for this excellent work! (Closes: #441608)
+ * doc/ja/*, doc/po/ja.po:
+ - remove the old ja man page translation and replace it with
+ the new po4a-powered translation by KURASAWA Nozomu.
+ * doc/*.?.xml (manpages):
+ - add contrib to author tags and also add refmiscinfo to fix warnings
+ * doc/style.txt, buildlib/defaults.mak, buildlib/manpage.mak:
+ - fix a few typos in the comments of this files
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - when tcgetattr() returns non-zero skip all pty magic
+ (thanks to Simon Richter, closes: #509866)
+ * apt-inst/contrib/arfile.cc:
+ - show propper error message for Invalid archive members
+
+ [ David Kalnischkies ]
+ * doc/Doxyfile.in:
+ - update file with doxygen 1.6.1 (current unstable)
+ - activate DOT_MULTI_TARGETS, it is default on since doxygen 1.5.9
+ * buildlib/po4a_manpage.mak, doc/makefile, configure:
+ - simplify the makefiles needed for po4a manpages
+ * apt-pkg/contrib/configuration.cc:
+ - add a helper to easily get a vector of strings from the config
+ * apt-pkg/contrib/strutl.cc:
+ - replace unknown multibytes with ? in UTF8ToCharset (Closes: #545208)
+ * doc/apt-get.8.xml:
+ - fix two little typos in the --simulate description. (Closes: #545059)
+ * apt-pkg/aptconfiguration.cc, doc/apt.conf.5.xml:
+ - add an order subgroup to the compression types to simplify reordering
+ a bit and improve the documentation for this option group.
+ * doc/apt.conf.5.xml:
+ - document the Acquire::http::Dl-Limit option
+ - try to be crystal clear about the usage of :: and {} (Closes: #503481)
+ * doc/apt-cache.8.xml:
+ - clarify the note for the pkgnames command (Closes: #547599)
+ * doc/apt.ent, all man pages:
+ - move the description of files to globally usable entities
+ * doc/apt_preferences.5.xml:
+ - document the new preferences.d folder (Closes: #544017)
+ * methods/rred.cc:
+ - add at the top without failing (by Bernhard R. Link, Closes: #545694)
+ * buildlib/sizetable:
+ - add amd64 for cross building (by Mikhail Gusarov, Closes: #513058)
+ * debian/prerm:
+ - remove file as nobody will upgrade from 0.4.10 anymore
+ * debian/control:
+ - remove gnome-apt suggestion as it was removed from debian
+ * apt-pkg/deb/dpkgpm.cc, apt-pkg/packagemanager.cc, apt-pkg/orderlist.cc:
+ - add and document _experimental_ options to make (aggressive)
+ use of dpkg's trigger and configuration handling (Closes: #473461)
+ * cmdline/apt-get.cc:
+ - ignore versions that are not candidates when selecting a package
+ instead of a virtual one (by Marius Vollmer, Closes: #547788)
+
+ [ Christian Perrier ]
+ * doc/fr/*, doc/po/fr.po:
+ - remove the old fr man page translation and replace it with
+ the new po4a-powered translation
+ * doc/de: dropped (translation is too incomplete to be useful in
+ the transition to the po4a-powered translations)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 25 Sep 2009 19:57:25 +0200
+
+apt (0.7.23.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/pkgcache.cc:
+ - do not set internel "needs-configure" state for packages in
+ triggers-pending state. dpkg will deal with the trigger and
+ it if does it before we trigger it, dpkg will error out
+ (LP: #414631)
+ * apt-pkg/acquire-item.cc:
+ - do not segfault on invalid items (closes: #544080)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 28 Aug 2009 21:53:20 +0200
+
+apt (0.7.23) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * methods/{http,https,ftp}, doc/apt.conf.5.xml:
+ - Changed and unified the code that determines which proxy to use. Now
+ 'Acquire::{http,ftp}::Proxy[::<host>]' options have the highest priority,
+ and '{http,ftp}_proxy' environment variables are used only if options
+ mentioned above are not specified.
+ (Closes: #445985, #157759, #320184, #365880, #479617)
+