]> git.saurik.com Git - apt.git/blobdiff - debian/rules
merged from debian
[apt.git] / debian / rules
index 8e2b18f67a8bb696e00b1b65b4f3b790ad13d345..2a18f4f47c83cc7c39727fd570bae5c21f3000cd 100755 (executable)
@@ -186,6 +186,7 @@ apt-doc: build-doc
 # Build architecture-dependent files here.
 
 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
 apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -232,7 +233,7 @@ apt: build build-doc debian/shlibs.local
           debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ 
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
@@ -275,6 +276,7 @@ libapt-pkg-dev: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -290,7 +292,7 @@ apt-utils: build debian/shlibs.local
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@