]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/cacheiterators.h:
[apt.git] / debian / changelog
index 58cff6822812dc5b3889def1ecc1010d1c87bcf7..7070c5fc912406679ced1e4bea76dc6cb71d8909 100644 (file)
@@ -5,6 +5,18 @@ apt (0.9.7.8~exp2+nmu1) UNRELEASED; urgency=low
   * apt-pkg/pkgcachegen.cc:
     - do not store the MD5Sum for every description language variant as
       it will be the same for all so it can be shared to save cache space
+    - handle language tags for descriptions are unique strings to be shared
+    - factor version string creation out of NewDepends, so we can easily reuse
+      version strings e.g. for implicit multi-arch dependencies
+    - equal comparisions are used mostly in same-source relations,
+      so use this to try to reuse some version strings
+    - sort group and package names in the hashtable on insert
+  * apt-pkg/pkgcache.cc:
+    - assume sorted hashtable entries for groups/packages
+  * apt-pkg/cacheiterators.h:
+    - provide DepIterator::IsSatisfied as a nicer shorthand for DepCheck
+  * apt-pkg/deb/debversion.cc:
+    - add a string-equal shortcut for equal version comparisions
 
  -- David Kalnischkies <kalnischkies@gmail.com>  Sun, 10 Mar 2013 12:23:24 +0100