# (http://savannah.gnu.org/bugs/?10593)
dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
export CXXFLAGS = $(shell $(dpkg_buildflags) --get CXXFLAGS)
- # we can not use "-Wl,-Bsymbolic-functions" with the new weak symbols
- # in libapt-private (commit 28f24d3d added those)
- comma:= ,
- export LDFLAGS = $(subst -Wl$(comma)-Bsymbolic-functions,,$(shell $(dpkg_buildflags) --get LDFLAGS))
+ export LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
export CPPFLAGS = $(shell $(dpkg_buildflags) --get CPPFLAGS)
else
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
override BLD := ./build
endif
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
+
# APT Programs in apt-utils
APT_UTILS=ftparchive sortpkgs extracttemplates