]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Update symbols file
[apt.git] / debian / rules
index 9a7c72080375418df57664112d505629e7612db9..ce7d19dec4529c1785cc79c0fd1d31f7d8cf91fd 100755 (executable)
@@ -29,10 +29,7 @@ ifneq (,$(shell which dpkg-buildflags))
   # (http://savannah.gnu.org/bugs/?10593)
   dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
   export CXXFLAGS = $(shell $(dpkg_buildflags) --get CXXFLAGS)
-  # we can not use "-Wl,-Bsymbolic-functions" with the new weak symbols
-  # in libapt-private (commit 28f24d3d added those)
-  comma:= ,
-  export LDFLAGS = $(subst -Wl$(comma)-Bsymbolic-functions,,$(shell $(dpkg_buildflags) --get LDFLAGS))
+  export LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
   export CPPFLAGS = $(shell $(dpkg_buildflags) --get CPPFLAGS)
 else
   ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -63,6 +60,11 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
+
 # APT Programs in apt-utils
 APT_UTILS=ftparchive sortpkgs extracttemplates