]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* apt-pkg/cacheiterator.h:
[apt.git] / debian / rules
index f1cb77fbebc03893948cf25a346eaf9ffb3ffc7a..827fc203487ebefce9239e0dcc61c1fa53675f62 100755 (executable)
@@ -27,10 +27,14 @@ endif
 # See below
 -include build/environment.mak
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+  export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
 else
-  export CXXFLAGS = -O2 -g -Wall
+  ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    export CXXFLAGS = -O0 -g -Wall
+  else
+    export CXXFLAGS = -O2 -g -Wall
+  endif
 endif
 
 # Default rule