-apt (0.7.11) UNRELEASED; urgency=low
+apt (0.7.15) unstable; urgency=low
+
+ * Upload to unstable
+
+ -- Michael Vogt <mvo@debian.org> Sun, 05 Oct 2008 13:23:47 +0200
+
+apt (0.7.15~exp3) experimental; urgency=low
+
+ [Daniel Burrows]
+ * apt-pkg/deb/dpkgpm.cc:
+ - Store the trigger state descriptions in a way that does not break
+ the ABI. The approach taken makes the search for a string O(n) rather
+ than O(lg(n)), but since n == 4, I do not consider this a major
+ concern. If it becomes a concern, we can sort the static array and
+ use std::equal_range(). (Closes: #499322)
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.cc, apt-pkg/deb/dpkgpm.cc:
+ - move the state file writting into the Go() implementation
+ of dpkgpm (closes: #498799)
+ * apt-pkg/algorithms.cc:
+ - fix simulation performance drop (thanks to Ferenc Wagner
+ for reporting the issue)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 01 Oct 2008 18:09:49 +0200
+
+apt (0.7.15~exp2) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/pkgcachegen.cc:
+ - do not add multiple identical descriptions for the same
+ language (closes: #400768)
+
+ [ Program translations ]
+ * Catalan updated. Closes: #499462
+
+ -- Michael Vogt <mvo@debian.org> Tue, 23 Sep 2008 07:29:59 +0200
+
+apt (0.7.15~exp1) experimental; urgency=low
+
+ [ Christian Perrier ]
+ * Fix typo in cron.daily script. Closes: #486179
+
+ [ Program translations ]
+ * Traditional Chinese updated. Closes: #488526
+ * German corrected and completed. Closes: #490532, #480002, #498018
+ * French completed
+ * Bulgarian updated. Closes: #492473
+ * Slovak updated. Closes: #492475
+ * Galician updated. Closes: #492794
+ * Japanese updated. Closes: #492975
+ * Fix missing space in Greek translation. Closes: #493922
+ * Greek updated.
+ * Brazilian Portuguese updated.
+ * Basque updated. Closes: #496754
+ * Romanian updated. Closes: #492773, #488361
+ * Portuguese updated. Closes: #491790
+ * Simplified Chinese updated. Closes: #489344
+ * Norwegian Bokmål updated. Closes: #480022
+ * Czech updated. Closes: #479628, #497277
+ * Korean updated. Closes: #464515
+ * Spanish updated. Closes: #457706
+ * Lithuanian added. Closes: #493328
+ * Swedish updated. Closes: #497496
+ * Vietnamese updated. Closes: #497893
+ * Portuguese updated. Closes: #498411
+ * Greek updated. Closes: #498687
+ * Polish updated.
+
+ [ Michael Vogt ]
+ * merge patch that enforces stricter https server certificate
+ checking (thanks to Arnaud Ebalard, closes: #485960)
+ * allow per-mirror specific https settings
+ (thanks to Arnaud Ebalard, closes: #485965)
+ * add doc/examples/apt-https-method-example.cof
+ (thanks to Arnaud Ebalard, closes: #485964)
+ * apt-pkg/depcache.cc:
+ - when checking for new important deps, skip critical ones
+ (closes: #485943)
+ * improve apt progress reporting, display trigger actions
+ * add DPkg::NoTriggers option so that applications that call
+ apt/aptitude (like the installer) defer trigger processing
+ (thanks to Joey Hess)
+ * doc/makefile:
+ - add examples/apt-https-method-example.conf
+
+ -- Michael Vogt <mvo@debian.org> Tue, 16 Sep 2008 21:27:03 +0200
+
+apt (0.7.14) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Mark a message from dselect backend as translatable
+ Thanks to Frédéric Bothamy for the patch
+ Closes: #322470
+
+ [ Program translations ]
+ * Simplified Chinese updated. Closes: #473360
+ * Catalan fixes. Closes: #387141
+ * Typo fix in Greek translation. Closes: #479122
+ * French updated.
+ * Thai updated. Closes: #479313
+ * Italian updated. Closes: #479326
+ * Polish updated. Closes: #479342
+ * Bulgarian updated. Closes: #479379
+ * Finnish updated. Closes: #479403
+ * Korean updated. Closes: #479426
+ * Basque updated. Closes: #479452
+ * Vietnamese updated. Closes: #479748
+ * Russian updated. Closes: #479777, #499029
+ * Galician updated. Closes: #479792
+ * Portuguese updated. Closes: #479847
+ * Swedish updated. Closes: #479871
+ * Dutch updated. Closes: #480125
+ * Kurdish added. Closes: #480150
+ * Brazilian Portuguese updated. Closes: #480561
+ * Hungarian updated. Closes: #480662
+
+ [ Otavio Salvador ]
+ * Apply patch to avoid truncating of arbitrary files. Thanks to Bryan
+ Donlan <bdonlan@fushizen.net> for the patch. Closes: #482476
+ * Avoid using dbus if dbus-daemon isn't running. Closes: #438803
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - apply patch based on the ideas of Francesco Poli for better
+ behavior when the cache can not be locked (closes: #459344)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 28 May 2008 15:19:12 +0200
+
+apt (0.7.13) unstable; urgency=low
+
+ [ Otavio Salvador ]
+ * Add missing build-depends back from build-depends-indep field.
+ Closes: #478231
+ * Make cron script quiet if cache is locked. Thanks to Ted Percival
+ <ted@midg3t.net> for the patch. Closes: #459344
+ * Add timeout support for https. Thanks to Andrew Martens
+ <andrew.martens@strangeloopnetworks.com> for the patch.
+
+ [ Goswin von Brederlow ]
+ * Add support for --no-download on apt-get update. Closes: #478517
+
+ [ Program translations ]
+ - Vietnamese updated. Closes: #479008
+
+ -- Otavio Salvador <otavio@debian.org> Fri, 02 May 2008 14:46:00 -0300
+
+apt (0.7.12) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * cmdline/apt-key:
+ - add support for a master-keyring that contains signing keys
+ that can be used to sign the archive signing keys. This should
+ make key-rollover easier.
+ * apt-pkg/deb/dpkgpm.cc:
+ - merged patch from Kees Cook to fix anoying upper-case display
+ on amd64 in sbuild
+ * apt-pkg/algorithms.cc:
+ - add APT::Update::Post-Invoke-Success script slot
+ - Make the breaks handling use the kill list. This means, that a
+ Breaks: Pkg (<< version) may put Pkg onto the remove list.
+ * apt-pkg/deb/debmetaindex.cc:
+ - add missing "Release" file uri when apt-get update --print-uris
+ is run
+ * methods/connect.cc:
+ - remember hosts with Resolve failures or connect Timeouts
+ * cmdline/apt-get.cc:
+ - fix incorrect help output for -f (LP: #57487)
+ - do two passes when installing tasks, first ignoring dependencies,
+ then resolving them and run the problemResolver at the end
+ so that it can correct any missing dependencies
+ * debian/apt.cron.daily:
+ - sleep random amount of time (default within 0-30min) before
+ starting the upate to hit the mirrors less hard
+ * doc/apt_preferences.5.xml:
+ - fix typo
+ * added debian/README.source
+
+ [ Christian Perrier ]
+ * Fix typos in manpages. Thanks to Daniel Leidert for the fixes
+ Closes: #444922
+ * Fix syntax/copitalisation in some messages. Thanks to Jens Seidel
+ for pointing this and providing the patch.
+ Closes: #466845
+ * Fix Polish offline translation. Thanks to Robert Luberda for the patch
+ and apologies for applying it very lately. Closes: #337758
+ * Fix typo in offline.sgml. Closes: #412900
+
+ [ Program translations ]
+ - German updated. Closes: #466842
+ - Swedish updated.
+ - Polish updated. Closes: #469581
+ - Slovak updated. Closes: #471341
+ - French updated.
+ - Bulgarian updated. Closes: #448492
+ - Galician updated. Closes: #476839
+
+ [ Daniel Burrows ]
+ * apt-pkg/depcache.cc:
+ - Patch MarkInstall to follow currently satisfied Recommends even
+ if they aren't "new", so that we automatically force upgrades
+ when the version of a Recommends has been tightened. (Closes: #470115)
+ - Enable more complete debugging information when Debug::pkgAutoRemove
+ is set.
+ * apt-pkg/contrib/configuration.cc
+ - Lift the 1024-byte limit on lines in configuration files.
+ (Closes: #473710, #473874)
+ * apt-pkg/contrib/strutl.cc:
+ - Lift the 64000-byte limit on individual messages parsed by ReadMessages.
+ (Closes: #474065)
+ * debian/rules:
+ - Add missing Build-Depends-Indep on xsltproc, docbook-xsl, and xmlto.
+
+ -- Daniel Burrows <dburrows@debian.org> Sat, 26 Apr 2008 12:24:35 -0700
+
+apt (0.7.11) unstable; urgency=critical
+
+ [ Raise urgency to critical since it fixes a critical but for Debian
+ Installer Lenny Beta1 release ]
[ Program translations ]
- Vietnamese updated. Closes: #460825
* Fix regression about APT::Get::List-Cleanup setting being ignored,
closes: #466052.
- -- Otavio Salvador <otavio@ossystems.com.br> Thu, 17 Jan 2008 22:36:46 -0200
+ -- Otavio Salvador <otavio@debian.org> Thu, 17 Jan 2008 22:36:46 -0200
apt (0.7.10) unstable; urgency=low