]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
Drop Privileges to "Debian-apt" in most acquire methods
[apt.git] / debian / apt.postinst
index fd3e273bb79c61410e5c6463a0c76cea3e824ed2..08dc60f9ca047c0952832a1ff94f6e830ffb487c 100644 (file)
@@ -26,6 +26,13 @@ case "$1" in
            fi
        fi
 
+        # add unprivileged user for the apt methods
+        adduser --force-badname --system --no-create-home \
+            --quiet Debian-apt || true
+        chown -R Debian-apt:root \
+            /var/lib/apt/lists \
+            /var/cache/apt/archives
+
         # ensure tighter permissons on the logs, see LP: #975199
         if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then
             # ensure permissions are right