* apt-pkg/deb/dpkgpm.cc:
- chroot if needed before dpkg --assert-multi-arch
- ensure that dpkg binary doesn't have the chroot-directory prefixed
+ - call dpkg --assert-multi-arch with execvp instead of execv
+ - save the universe by not printing messages about apport if a package
+ with this name is not installed (Closes: #619646)
* apt-pkg/depcache.cc:
- if a M-A:same package is marked for reinstall, mark all it's installed
silbings for reinstallation as well (LP: #859188)
- if a file without an extension is requested send an 'Accept: text/*'
header to avoid that the server chooses unsupported compressed files
in a content-negotation attempt (Closes: #657560)
+ - remove the arbitrary MAXLEN limit for response lines (Closes: #658346)
* apt-pkg/aptconfiguration.cc:
- chroot if needed before calling dpkg --print-foreign-architectures
+ - ensure that architectures are not added multiple times
+ * cmdline/apt-mark.cc:
+ - detect if dpkg has multiarch support before calling --set-selections
+ - correctly ignore already (un)hold packages
+ * apt-pkg/cachefile.cc:
+ - clean up lost atomic cachefiles with 'clean' (Closes: #650513)
+ * apt-pkg/indexrecords.cc:
+ - do not create empty Entries as a sideeffect of Lookup()
[ Steve Langasek ]
* cmdline/apt-get.cc:
of them in a single iteration (Closes: #657695, LP: #922485)
- use a signed int instead of short for score calculation as upgrades
become so big now that it can overflow (Closes: #657732, LP: #917173)
-
+ * Fix IndexCopy::CopyPackages and TranslationsCopy::CopyTranslations to
+ handle compressed files again (LP: #924182, closes: #658096)
+
[ Michael Vogt ]
* apt-pkg/deb/dpkgpm.cc:
- fix crash when a package is in removed but residual config state
(LP: #923807)
+ * apt-pkg/contrib/fileutl.h:
+ - fix compat with FileFd::OpenDescriptor() in ReadOnlyGzip mode
- -- David Kalnischkies <kalnischkies@gmail.com> Mon, 30 Jan 2012 19:17:09 +0100
+ -- David Kalnischkies <kalnischkies@gmail.com> Sat, 18 Feb 2012 18:22:14 +0100
apt (0.8.16~exp12) experimental; urgency=low