]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Update version number
[apt.git] / debian / rules
index 144189189c7c8c14b3463b7e5614fe7daf3c10a2..0ac423c92c9e17de3ee31cdd039e926c4a2633f0 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.49 2003/04/27 06:20:40 doogie Exp $
+# $Id: rules,v 1.62 2003/12/24 22:55:30 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -14,8 +14,6 @@
 # create ../upload-<VER>, with all the files needed to be uploaded placed
 # in it.
 
-export DH_COMPAT=2
-
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
@@ -32,7 +30,7 @@ endif
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild -us -uc
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 
@@ -55,7 +53,7 @@ endif
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
 .PHONY: configure.in
 configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
 else
 configure.in:
 endif
@@ -101,14 +99,6 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-ifneq ($(wildcard /usr/share/misc/config.sub),)
-       cp -a /usr/share/misc/config.sub buildlib/config.sub
-       echo Updating buildlib/config.sub
-endif
-ifneq ($(wildcard /usr/share/misc/config.guess),)
-       cp -a /usr/share/misc/config.guess buildlib/config.guess
-       echo Updating buildlib/config.guess
-endif
        cd build && ../configure $(confflags)
        touch $@
 
@@ -150,7 +140,7 @@ libapt-pkg-doc: build-doc debian/shlibs.local
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
 #      dh_undocumented -p$@
        dh_installchangelogs -p$@
@@ -190,7 +180,7 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share
+       dh_installdirs -p$@ /usr/share/bug/$@
 #
 # apt install
 #
@@ -208,20 +198,22 @@ apt: build debian/shlibs.local
        cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/apt/usr/share/
 
+       cp debian/bugscript debian/apt/usr/share/bug/apt/script
+
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
+       dh_installman -p$@ 
 
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
        dh_installdeb -p$@
        dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
-       dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -242,7 +234,7 @@ libapt-pkg-dev: build debian/shlibs.local
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -268,17 +260,16 @@ apt-utils: build debian/shlibs.local
        dh_installdocs -p$@
 
        # Install the man pages..
-       mkdir -p debian/$@/usr/share/man/man1
-       -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
+       dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_installdeb -p$@
        LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
-       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -317,10 +308,10 @@ binary: binary-indep binary-arch
 
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update
+       cvs update -d
        $(MAKE) startup
        $(MAKE) doc
-       tar c --exclude CVS --exclude cvs-build . |\
+       tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
                (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
        (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))