]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
Switch FileFd to not transparently gunzip, since that breaks code which expects the...
[apt.git] / debian / changelog
index e44d7986d9e06cdb0071f8d8e7c8e037b8c1c952..f3f2d3df43ccb9e80acce1c0424334908ad4c20d 100644 (file)
@@ -9,13 +9,17 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
     - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
       CXXFLAGS.
   * apt-pkg/contrib/fileutl.{h,cc}:
-    - Add support for transparent reading of gzipped files.
+    - Add support for reading of gzipped files with the new "ReadOnlyGzip"
+      OpenMode.
     - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
     - [ABI BREAK] This adds a new private member to FileFd, but its
-      initialization is in the public header file. This also changes the
-      behaviour of FileFd for reading gzipped files.
+      initialization is in the public header file.
   * configure.in:
     - Check for zlib library and headers.
+  * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
+    apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
+    cmdline/apt-cache.cc:
+    - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
   * apt-pkg/deb/debindexfile.cc:
     - If we do not find uncompressed package/source/translation indexes, look
       for gzip compressed ones.