- Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
CXXFLAGS.
* apt-pkg/contrib/fileutl.{h,cc}:
- - Add support for transparent reading of gzipped files.
+ - Add support for reading of gzipped files with the new "ReadOnlyGzip"
+ OpenMode.
- Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
- [ABI BREAK] This adds a new private member to FileFd, but its
- initialization is in the public header file. This also changes the
- behaviour of FileFd for reading gzipped files.
+ initialization is in the public header file.
* configure.in:
- Check for zlib library and headers.
+ * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
+ apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
+ cmdline/apt-cache.cc:
+ - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
* apt-pkg/deb/debindexfile.cc:
- If we do not find uncompressed package/source/translation indexes, look
for gzip compressed ones.