-apt (0.8.15) UNRELEASED; urgency=low
+apt (0.8.15.2) unstable; urgency=high
+
+ * fix from David Kalnischkies for the InRelease gpg verification
+ code (LP: #784473)
+ * cmdline/apt-get.cc:
+ - fix missing download progress in apt-get download
+ * apt-pkg/contrib/cdromutl.cc:
+ - fix escape problem when looking for the mounted devices
+ * apt-pkg/contrib/strutl.{h,cc}, test/libapt/strutil_test.cc:
+ - add new DeEscapeString() similar to DeQuoteString but
+ unescape character escapes like \0XX and \xXX (plus added
+ test)
+ * apt-pkg/contrib/fileutl.{cc,h}:
+ - add GetModificationTime() helper
+ * apt-pkg/pkgcachegen.cc:
+ - regenerate the cache if the sources.list changes to ensure
+ that changes in the ordering there will be honored by apt
+ * apt-pkg/sourcelist.{cc,h}:
+ - add pkgSourceList::GetLastModifiedTime() helper
+ * apt-pkg/pkgcachegen.{cc,h}:
+ - use ref-to-ptr semantic in NewDepends() to ensure that the
+ libapt does not segfault if the cache is remapped in between
+ (LP: #812862)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 12 Jul 2011 11:54:47 +0200
+
+apt (0.8.15.1) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * doc/makefile:
+ - create doxygen directory to avoid depending on magic (Closes: #628799)
+ * cmdline/apt-key:
+ - explicitly state that net-update is not supported if no url is set
+ - require to be root for add, rm, update and net-update
+ - clarify update vs. net-update in different distros (Closes: #632043)
+ * debian/apt.symbols:
+ - forgot 'mips' in the list for all architecture dependent symbols
+ - comment out gcc-4.5 specific symbols as gcc-4.6 is now default
+ - the symbol for PrintStatus() is architecture dependent
+ * apt-pkg/policy.cc:
+ - do not segfault in pinning if a package with this name doesn't exist.
+ Thanks to Ferdinand Thommes for the report!
+ - Defaults is a vector of Pin not of PkgPin
+ - ensure that only the first specific stanza for a package is used
+ - save all stanzas which had no effect in Unmatched
+ - allow package:architecure in Package:
+
+ -- Michael Vogt <mvo@debian.org> Thu, 30 Jun 2011 10:05:36 +0200
+
+apt (0.8.15) unstable; urgency=low
[ Julian Andres Klode ]
* apt-pkg/depcache.cc:
[ Christian Perrier ]
* Galician translation update (Miguel Anxo Bouzada). Closes: #626505
* Italian translation update (Milo Casagrande). Closes: #627834
+ * German documentation translation update (Chris Leick). Closes: #629949
+ * Catalan translation update (Jordi Mallach). Closes: #630657
[ David Kalnischkies ]
* fix a bunch of cppcheck warnings/errors based on a patch by
- let VisitRProvides report if the calls were successful
* apt-pkg/deb/dpkgpm.cc:
- replace obsolete usleep with nanosleep
+ - remove invalid pkgcache.bin and rebuild it if possible
+ - log reinstall commands in history.log
* debian/apt{,-utils}.symbols:
- update both experimental symbol-files to reflect 0.8.14 state
* debian/rules:
* apt-pkg/packagemanager.cc:
- ensure for Multi-Arch:same packages that they are unpacked in
lock step even in immediate configuration (Closes: #618288)
-
+ * apt-pkg/init.cc:
+ - don't set deprecated APT::Acquire::Translation, thanks Jörg Sommer!
+ * cmdline/apt-config.cc:
+ - show Acquire::Languages and APT::Architectures settings
+ in 'dump' (Closes: 626739)
+ * apt-pkg/orderlist.cc:
+ - ensure that an old version of a package with a provides can
+ never satisfy a dependency of a newer version of this package
+
[ Michael Vogt ]
* methods/mirror.cc:
- ignore lines starting with "#" in the mirror file
[ Kenneth Solbø Andersen ]
* apt-pkg/deb/dpkgpm.cc:
- set permissions of term.log to root.adm and 644 (LP: #404724)
+
+ [ Chris Leick ]
+ * various typo and syntax corrections in doc/*.xml
- -- Michael Vogt <mvo@debian.org> Mon, 16 May 2011 14:57:52 +0200
+ -- Michael Vogt <mvo@debian.org> Tue, 28 Jun 2011 18:00:48 +0200
apt (0.8.14.1) unstable; urgency=low