]> git.saurik.com Git - apt.git/blobdiff - debian/rules
fix foldmarker in algorithms.h
[apt.git] / debian / rules
index ef30568d5c9a680bbd255c8552a18ac4c21be260..30474c06b71fb4cd9ac6adbd7a70a45119e97e52 100755 (executable)
@@ -100,7 +100,12 @@ build/build-stamp: build/configure-stamp
        # compat symlink for the locale split
        mkdir -p build/usr/share 
        cd build/usr/share && ln -f -s ../../locale .
-       # done here
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
        touch $@
 
 build/build-doc-stamp: build/configure-stamp
@@ -124,9 +129,6 @@ libapt-pkg-doc: build-doc
 #
 # libapt-pkg-doc install
 #
-       # remove doxygen's embedded jquery as we don't use it anyway (#622147)
-       rm -f $(BLD)/doc/doxygen/html/jquery.js
-
        dh_installdocs -p$@ $(BLD)/docs/design* \
                            $(BLD)/docs/dpkg-tech* \
                            $(BLD)/docs/files* \