]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Don't download "optional" files not in Release :/.
[apt.git] / debian / rules
index 24608a6b8eb575c8d0bd14deea40f8e8bfc220b2..62d913f0aafe29d2b2ab5913054fbc67c5e88f39 100755 (executable)
@@ -29,8 +29,16 @@ override_dh_gencontrol:
 override_dh_installcron:
        dh_installcron --name=apt-compat
 
+override_dh_systemd_start:
+       # Do not restart "apt-daily.service" because this script runs
+       # unattended-upgrades. So if apt itself is upgraded as part of
+       # an unattended-upgrades run it would kill itself
+       dh_systemd_start apt-daily.timer
 
 override_dh_auto_configure-arch: flags=-DWITH_DOC=OFF
 override_dh_auto_configure-indep: flags=-DWITH_DOC=ON
 override_dh_auto_configure-arch override_dh_auto_configure-indep:
        dh_auto_configure -- $(flags)
+
+override_dh_auto_build:
+       dh_auto_build -- -O