]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Make sure we always have at least two kernels marked not for removal
[apt.git] / debian / rules
index 00e6bd4b7e5aaa159285d4b4cd4b63375fdf8bc8..3979bd810301e8c224fb7daa7679baa6e03d72ad 100755 (executable)
@@ -34,9 +34,6 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
-APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"\(.*\)")/\1/p' configure.in)
-APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -53,19 +50,8 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
-# Rebuild configure.in to have the correct version from the change log
-ifneq ($(APT_DEBVER),$(APT_CONFVER))
-ifneq ($(APT_DEBVER),)
-.PHONY: configure.in
-configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
-endif
-else
-configure.in:
-endif
-
 # APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
+APT_UTILS=ftparchive sortpkgs extracttemplates
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -81,7 +67,8 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
 build: build/build-stamp
-build-doc: build/build-doc-stamp
+build-debiandoc: build/build-debiandoc-stamp
+build-manpages: build/build-manpages-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -111,13 +98,19 @@ else
 endif
        touch $@
 
-build/build-doc-stamp: build/configure-stamp
+build/build-debiandoc-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) debiandoc
+       touch $@
+
+build/build-manpages-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) doc
+       $(MAKE) manpages
        touch $@
 
 clean:
        dh_testdir
+       dh_clean
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
@@ -129,7 +122,7 @@ debian/%.install: debian/%.install.in
 
 binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build-doc
+libapt-pkg-doc: build-debiandoc
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -155,7 +148,7 @@ libapt-pkg-doc: build-doc
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-doc: build-doc
+apt-doc: build-debiandoc
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -180,8 +173,8 @@ apt-doc: build-doc
 # Build architecture-dependent files here.
 
 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
-apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-doc
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -190,6 +183,8 @@ apt: build build-doc
 # apt install
 #
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+       cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
@@ -199,7 +194,7 @@ apt: build build-doc
        dh_install -p$@ --sourcedir=$(BLD)
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
 
        # https has its own package
        rm debian/$@/usr/lib/apt/methods/https
@@ -211,7 +206,7 @@ apt: build build-doc
        dh_bugfiles -p$@
        dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
@@ -245,7 +240,7 @@ libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_builddeb -p$@
 
 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build
+apt-utils: build build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -253,6 +248,7 @@ apt-utils: build
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+       cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
 
        dh_install -p$@ --sourcedir=$(BLD)
        dh_link -p$@
@@ -260,7 +256,7 @@ apt-utils: build
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@