]> git.saurik.com Git - apt.git/blobdiff - debian/rules
use *.docs files instead of hardcoding in debian/rules
[apt.git] / debian / rules
index c8e7cb285bed743f8ac9afbae0e645d5ef86387d..cbe7e70b6106ed4025010f445a7fc2d4cdf32201 100755 (executable)
@@ -42,23 +42,14 @@ endif
 # Default rule
 build:
 
-PKG=apt
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-
 # Determine the build directory to use
-BASE=.
-ifdef BUILD
-BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
-else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
-endif
-BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
-BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
-override BLD := $(BUILDX)
+override BASE := .
+override BLD := $(BASE)/build
 
-ifeq ($(words $(BLD)),0)
-override BLD := ./build
-endif
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
 
 # APT Programs in apt-utils
 APT_UTILS=ftparchive sortpkgs extracttemplates
@@ -142,15 +133,9 @@ libapt-pkg-doc: build-docbook
 # libapt-pkg-doc install
 #
        rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
-       dh_installdocs -p$@ $(BLD)/docs/design* \
-                           $(BLD)/docs/dpkg-tech* \
-                           $(BLD)/docs/files* \
-                           $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt \
-                           doc/style.txt \
-                           $(BLD)/doc/doxygen/html
+       dh_installdocs -p$@
        dh_installexamples -p$@
-
+       dh_lintian -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@ -X.xhtml
@@ -168,10 +153,7 @@ apt-doc: build-docbook
 # apt-doc install
 #
        # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text \
-                           $(BLD)/docs/guide*.html \
-                           $(BLD)/docs/offline*.text \
-                           $(BLD)/docs/offline*.html
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -217,13 +199,17 @@ apt: build-binary build-manpages debian/apt.install
        #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
        # move the apt-helper in place
-       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper 
+       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+       # install apt.systemd.daily helper in the right place
+       install -m755 debian/apt.systemd.daily debian/$@/usr/lib/apt/
 
        dh_bugfiles -p$@
        dh_lintian -p$@
-       dh_installexamples -p$@ $(BLD)/docs/examples/*
+       dh_installexamples -p$@
        dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
-       dh_installcron -p$@
+       dh_installcron -p$@ --name=apt-compat
+       dh_systemd_enable -p$@ apt-daily.timer
+       dh_systemd_start -p$@ apt-daily.timer
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_installlogrotate -p$@
@@ -319,7 +305,7 @@ $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
        dh_fixperms -p$@
        dh_makeshlibs -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ 
+       dh_shlibdeps -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -331,7 +317,7 @@ apt-transport-https: build-binary libapt-pkg-dev
        dh_installdirs -p$@
 
        dh_install -p$@ --sourcedir=$(BLD)
-       dh_installdocs -p$@ debian/apt-transport-https.README
+       dh_installdocs -p$@
        dh_installexamples -p$@
 
        # Install the man pages..
@@ -342,7 +328,7 @@ apt-transport-https: build-binary libapt-pkg-dev
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ 
+       dh_shlibdeps -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@