]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Typo in the package description. Closes: #60230
[apt.git] / debian / rules
index e3e731cc62881411e881d72f0e2e81f9a08f9821..05dbc460376bd810f07fdbefedadce0b8f3b8e21 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.14 1999/04/07 06:34:57 jgg Exp $
+# $Id: rules,v 1.19 1999/12/07 07:38:19 jgg Exp $
 
 
 # For the deb builder, you can run 'debian/rules cvs-build', which does all
 # create ../upload-<VER>, with all the files needed to be uploaded placed
 # in it.
 
-DEB_BUILD_PROG:=debuild
+DEB_BUILD_PROG:=debuild -us -uc
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 
+# Determine the build directory to use
+BASE=.
+ifdef BUILD
+BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
+else
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+endif
+BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
+BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
+override BLD := $(BUILDX)
+
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
 .PHONY: configure.in
 configure.in:
@@ -42,7 +53,7 @@ build-stamp: configure
 #      cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
 #      cd build && make all-hdr
 #      cd build && make -s
-       
+
        # Add here commands to compile the package.
        make
        touch build-stamp
@@ -67,16 +78,18 @@ libapt-pkg-doc: build debian/shlibs.local
        dh_installdirs -p$@
 #
 # libapt-pkg-doc install
-#
-       -cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
-         build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
-       cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-       dh_installdocs -p$@
+#      
+       dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
+                            $(BLD)/docs/files* $(BLD)/docs/method*
+                           
+       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
+       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
+       
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-       dh_installmanpages -p$@
+#      dh_installmanpages -p$@
 
 #      dh_undocumented -p$@
        dh_installchangelogs -p$@
@@ -101,44 +114,33 @@ apt: build debian/shlibs.local
 #
 # apt install
 #
-       cp build/bin/apt-* debian/tmp/usr/bin/
+       cp $(BLD)/bin/apt-* debian/tmp/usr/bin/
        
        # install the shared libs
-       find build/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
-       find build/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
+       find $(BLD)/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
+       find $(BLD)/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
 
-       cp build/bin/methods/* debian/tmp/usr/lib/apt/methods/
+       cp $(BLD)/bin/methods/* debian/tmp/usr/lib/apt/methods/
 
-       cp build/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
-#      cp debian/sources.list debian/tmp/etc/apt/
+       cp $(BLD)/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
 
-       # Copy the users guide  
-       -cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
-       -cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
+       # Copy the guides
+       dh_installdocs -p$@ $(BLD)/docs/guide.text $(BLD)/docs/guide.html \
+                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
        
-       # Copy the offline guide        
-       -cp build/docs/offline.text debian/tmp/usr/doc/apt/offline.txt
-       -cp -a build/docs/offline.html/* debian/tmp/usr/doc/apt/offline.html/
-       
-       cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
+       # One or the other..
+       -cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
+       -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp 
        
 #      head -n 500 ChangeLog > debian/ChangeLog
 
-
-
-       dh_installdocs -p$@
-       dh_installexamples -papt build/docs/examples/*
-#      dh_installmenu -papt
-#      dh_installinit -papt
-#      dh_installcron -papt
+       dh_installexamples -papt $(BLD)/docs/examples/*
        dh_installmanpages -p$@
 
-#      dh_undocumented -papt
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
        LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
@@ -154,14 +156,15 @@ libapt-pkg-dev: build debian/shlibs.local
 #
 # libapt-pkg-dev install
 #
-       ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
-       cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
+       cp -a $(BLD)/bin/libapt-pkg.so debian/libapt-pkg-dev/usr/lib/
+       #ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+       cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
 
        dh_installdocs -p$@
 #      dh_installmenu -papt
 #      dh_installinit -papt
 #      dh_installcron -papt
-       dh_installmanpages -p$@
+#      dh_installmanpages -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@