+apt (1.1~exp12) experimental; urgency=medium
+
+ [ David Kalnischkies ]
+ * sources.list and indextargets option for pdiffs
+ * auto-prefix $(SITE) for indextargets Description field
+ * implement PDiff patching for compressed files
+ * implement indextargets option 'DefaultEnabled'
+ * try xz instead of bz2 first for compressed files
+ * implement $(NATIVE_ARCHITECTURE) substvar for indextargets
+ * detect and deal with indextarget duplicates
+ * ignore for _apt inaccessible TMPDIR in pkgAcqChangelog (Closes: 797270)
+ * if file is inaccessible for _apt, disable privilege drop in acquire
+ * remove Christian Perrier from Uploaders as requested.
+ Thanks to Christian for all the l10n, code & social contributions!
+ (Closes: #783337)
+ * use unusable-for-security hashes for integrity checks
+ * use clock() as source for SRV randomness
+
+ [ Miroslav Kure ]
+ * Czech program translation update (Closes: 797329)
+
+ [ Michael Vogt ]
+ * Consider md5sum no longer a usable hash
+ * Add support for writing by-hash dirs in apt-ftparchive
+
+ [ Julian Andres Klode ]
+ * apt-pkg/tagfile.h: Include stdint.h, fixes rdep build failures
+
+ -- Michael Vogt <mvo@debian.org> Fri, 11 Sep 2015 23:31:34 +0200
+
+apt (1.1~exp11) experimental; urgency=medium
+
+ [ Julian Andres Klode ]
+ * pkgcachegen: Account for remapping when parsing depends from NewPackage.
+ Thanks to Jakub Wilk for the bug report and the backtraces (Closes: #796999)
+ * debian/rules: Only do parallel build if specified in DEB_BUILD_OPTIONS.
+ Thanks to Jakub Wilk for the suggestion
+ * cacheset: Prefer the depcache over the policy again
+ * install: Set a local deb as the candidate for that package
+ * Always close compressed files in FileFd
+ * Use compressor support from FileFd for ExtractTar instead of programs
+ * Do not parse Status fields from remote sources
+
+ [ David Kalnischkies ]
+ * just-in-time removal of broken essential packages (Closes: 796070)
+ * correct 'apt update' download summary line
+ * ignore AllowMem parameter in cache generation (Closes: 796459)
+ * add a libapt-pkg recommends apt
+ * fix various typos reported by codespell
+ * use always priv-dropping for changelog download as root
+ * allow explicit dis/enable of IndexTargets in sources options
+
+ [ Anders Jonsson ]
+ * Swedish program translation update (Closes: 796059)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 27 Aug 2015 17:55:12 +0200
+
+apt (1.1~exp10) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * add support for SRV record lookup before connect
+ * Provide "apt-get full-upgrade" to match "apt full-upgrade"
+ * Add support for "apt-cache showsrc --only-source srcpkgname"
+ Thanks to Steve Slangasek for the suggestion (Closes: 695633)
+
+ [ Julian Andres Klode ]
+ * Support tabs in sources.list files (Closes: #796067)
+ * Re-indent GetCandidateVerNew() and make ConsiderFiles argument explicit
+ * postinst: Correctly pass --home instead of -home, and fixup old user.
+ Thanks to Niels Thykier for reporting this on IRC
+
+ -- Michael Vogt <mvo@debian.org> Mon, 24 Aug 2015 10:12:15 +0200
+
+apt (1.1~exp9) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * Add "ca-certificates" recommends to apt-transport-https
+ * test/integration/test-apt-download-progress:
+ - fix test failure on fast hardware
+ * Rename "Size" in ServerState to TotalFileSize
+ * Make apt compile with clang++ again
+ * Cleanup includes (Thanks iwyu)
+
+ [ David Kalnischkies ]
+ * re-enable patchsize limit option for pdiffs
+ * better non-virtual metaIndex.LocalFileName() implementation
+ * mark internal interfaces as hidden
+ * restore ABI of pkgTagSection
+ * streamline display of --help in all tools
+ * allow uninstalled packages to be put on hold
+ * use 'best' hash for source authentication (LP: #1098738)
+ * re-enable support for -s (and co) in apt-get source (Closes: 742578)
+ * create directory for extended_states if needed
+ * create our cache and lib directory always with mode 755
+ * fix file ownership tests to work on kfreebsd
+ * use dpkg --merge-avail only if needed in apt-mark
+ * properly handle already reinstall pkgs in ordering (Closes: 770291)
+ * correct architecture detection for 'rc' packages for purge (Closes: 770898)
+ * derive more of https from http method
+ * properly implement pkgRecord::Parser for *.deb files
+ * improve https method queue progress reporting.
+ Thanks to Robert Edmonds and Anders Kaseorg for initial patchs
+ (Closes: 777565, 781509)
+ * calculate only expected hashes in methods
+ * calculate hashes while downloading in https
+ * ensure lists/ files have correct permissions after apt-cdrom add
+ * unsigned Release files can expire, too
+ * a hit on Release files means the indexes will be hits too
+ * remove "first package seen is native package" assumption.
+ Thanks to Axel Beckert for testing (Closes: 782777)
+ * improve partial/ cleanup in abort and failure cases
+ * a pin of 1000 always means downgrade allowed
+ * remove unused and strange default-value for pins
+ * show non-matching m-a:same versions in debug message
+ * fix 'Source' to 'Package' rename in apt-ftparchive
+ * sync TFRewrite*Order arrays with dpkg and dak
+ * stop depending on copy-on-write for std::string
+ * implement a more c++-style TFRewrite alternative
+ * rewrite all TFRewrite instances to use the new pkgTagSection::Write
+ * detect 416 complete file in partial by expected hash
+ * implement VerifyFile as all-hashes check
+ * detect Releasefile IMS hits even if the server doesn't
+ * treat older Release files than we already have as an IMSHit
+ * don't try other compressions on hashsum mismatch
+ * rework hashsum verification in the acquire system
+ * check patch hashes in rred worker instead of in the handler
+ * add more parsing error checking for rred
+ * support hashes for compressed pdiff files
+ * do not request files if we expect an IMS hit
+ * configurable acquire targets to download additional files
+ * show URI.Path in all acquire item descriptions
+ * implement 'apt-get files' to access index targets
+ * store Release files data in the Cache
+ * implement default apt-get file --release-info mode (Closes: 752702)
+ * populate the Architecture field for PackageFiles (Closes: 687255)
+ * hide Translation-* in 'apt-cache policy' output
+ * provide a public interface for acquiring changelogs
+ (Closes: 687147, 739854, 784027, 787190)
+ * ensure valid or remove destination file in file method
+ * deal better with acquiring the same URI multiple times
+ * call URIStart in cdrom and file method
+ * show item ID in Hit, Ign and Err lines as well
+ * condense parallel requests with the same hashes to one
+ * support lang= and target= sources.list options
+ * bring back deb822 sources.list entries as .sources
+ * detect and error out on conflicting Trusted settings
+ * merge indexRecords into metaIndex
+ * add sources.list Check-Valid-Until and Valid-Until-{Max,Min} options
+ * implement Signed-By option for sources.list
+ * remove the longtime deprecated vendor{,list} stuff
+ * allow individual targets to be kept compressed
+ * support gpg 2.1.x in apt-key (Closes: 781042)
+ * merge keyrings with cat instead of gpg in apt-key.
+ Thanks to Daniel Kahn Gillmor for the suggestion
+ * handle site-changing redirects as mirror changes
+ * disable locking even for root in --simulate
+ * rename 'apt-get files' to 'apt-get indextargets'
+ * enforce GCC5 C++11 ABI and usage
+ * show or-groups in not-installed recommends and suggests lists
+ * hide implicit deps in apt-cache again by default
+ * just-in-time creation for (explicit) negative deps
+ * add volatile sources support in libapt-pkg
+ * parse packages from all architectures into the cache
+ * enhance "hit paywall" error message to mention the probable cause
+ * drop extra newline in 'Failed to fetch' and 'GPG error' message
+ * mark again deps of pkgs in APT::Never-MarkAuto-Sections as manual.
+ Thanks to Raphaël Hertzog and Adam Conrad for detailed reports and
+ initial patches (Closes: 793360) (LP: #1479207)
+ * change to libapt-pkg abi 5.0 with versioned symbols
+ * move APT::Never-MarkAuto-Sections handling to MarkDelete
+ * move manual-bit from 'oldlibs' pkg to its dependencies
+ * remove Dir:: scope limit of RootDir in the documentation (Closes: 659387)
+ * add {contrib,non-free}/{metapackages,oldlibs} to section specialhandling
+ (Closes: 788320)
+
+ [ Frans Spiesschaert ]
+ * Dutch program translation update (Closes: 771039)
+
+ [ Julien Patriarca ]
+ * French program translation update (Closes: 766755)
+
+ [ Zhou Mo ]
+ * Chinese (simplified) program translation update (Closes: 766170)
+ * Chinese (simplified) program translation update (Closes: 771982)
+
+ [ Miroslav Kure ]
+ * Czech program translation update (Closes: 764055)
+
+ [ Mert Dirik ]
+ * Turkish program translation update (Closes: 763379)
+ * Turkish translation update for apt (Closes: #789491)
+
+ [ Kenshi Muto ]
+ * Japanese program translation update (Closes: 763033)
+ * Japanese program translation update (Closes: 772678)
+
+ [ James McCoy ]
+ * support long keyids in "apt-key del" instead of ignoring them
+ (Closes: 754436)
+ * tighten filtering of kernel images in apt.auto-removal (Closes: 772732)
+ * Use terminfo's typical save_cursor/restore_cursor sequences
+ (Closes: #772521)
+
+ [ Manuel "Venturi" Porras Peralta ]
+ * Spanish program translation update (Closes: 771815)
+
+ [ Jean-Pierre Giraud ]
+ * French manpages translation update (Closes: 771967)
+
+ [ Theppitak Karoonboonyanan ]
+ * Thai program translation update (Closes: 772913)
+
+ [ Tomasz Buchert ]
+ * Fix crash in the apt-transport-https when Owner is NULL (Closes: #778375)
+
+ [ Helmut Grohne ]
+ * parse arch-qualified Provides correctly (Closes: 777071)
+
+ [ Beatrice Torracca ]
+ * Italian manpage translation update (Closes: 776702)
+
+ [ Jérémy Bobbio ]
+ * stop displaying time of build in online help (Closes: 774342)
+
+ [ Robert Edmonds ]
+ * HttpsMethod::Fetch(): Zero the FetchResult object when leaving due to 404
+
+ [ Milo Casagrande ]
+ * Italian program translation update (Closes: 782122)
+
+ [ Julian Andres Klode ]
+ * pkgPolicy: Introduce storage and helpers for per-version pins
+ * versionmatch: Extract version match checking out of Find()
+ * policy: Assign per-version pins
+ * apt-cache: Change version pin output to use per-version pins
+ * fileutl_test.cc: Check for /etc/passwd instead of /bin/sh
+ * policy: Return highest file pin if version pin == 0 in GetPriority()
+ * Determine the candidate based on per-version pins, instead of old code
+ (Closes: #770017, #622237, #620249, #685215)
+ * policy: Fix the new policy implementation to handle downgrades correctly
+ * Fix test case breakage from the new policy implementation
+ * policy: Fix the handling of config-files states
+ * Replace INT_MIN with std::numeric_limits<int>::min
+ * Simply ignore cruft in the status files, do not treat it as prio 0
+ * Fix an obscure warning from GCC
+ * apt-get: Do not include apt-pkg/indexrecords.h
+ * Drop C++11 elements from headers
+ * Re-introduce None as a deprecated alias for No
+ * Make QItem a subclass of DescItem
+ * ExecFork: Use /proc/self/fd to determine which files to close
+ (Closes: #764204)
+ * Merge changelog entries from sid-gcc5
+ * Bump apt-inst SONAME to 2.0 to adjust for the ABI break in apt-pkg
+ * Annotate more methods with APT_OVERRIDE.
+ Thanks to g++ -Wsuggest-override
+ * debian/gbp.conf: Set multimaint-merge = True
+ * debian/control: Rename libapt-pkg4.15 -> libapt-pkg5.0
+ * apt.cron.daily: Reference 10periodic instead of 02periodic (LP: #1332106)
+ * Makefile: Add a make fast command for development
+ * Add a parameter ConsiderFiles to GetPriority(VerIterator)
+ * apt-cache: Modify policy output to use per-version pins
+ * Only make Upgradable() return true for packages with a candidate
+ (LP: #896689)
+ * apt-cache: Improve translateability of the "with priority" thing
+ * policy: Be more strict about parsing pin files, and document prio 0
+ (Closes: #429912)
+ * apt_preferences(5): Re-document how priorities are calculated
+ (Closes: #554773)
+ * Drop the Section field from pkgCache::Package again
+ * Fix integration tests for the removal of the Package pin output
+ * Remove an invalid fi from a testcase
+ * C++11: Switch from auto_ptr to unique_ptr
+ * Mark SPtr as deprecated, and convert users to std::unique_ptr
+ * Deprecate SPtrArray<T> and convert everyone to unique_ptr<T[]>
+ * Use setresuid() and setresgid() where available
+ * Accept --upgradeable as synonym for --upgradable (Closes: #787846)
+ * po/fr.po: Remove the unbreakable space before ! in the confirm string
+ (Closes: #727680)
+ * Replace --force-yes by various options starting with --allow
+ * Add integration test for Pin-Priority range checks
+ * Replace UINT_MAX with std::numeric_limits<unsigned int>::max()
+ * Mention that source order only matter per version (Closes: #617445)
+ * Say "in combination with the other options" if an option is not understood
+ (Closes: #762758)
+ * apt-cache: Show an error if stats gets any arguments (Closes: #153161)
+ * apt-cache(8): Mention that --names-only search provides (Closes: #618017)
+ * apt_preferences(5): Correct default pin assignment documentation
+ (Closes: #623706)
+ * apt_preferences(5): Mention overlapping of pin matches
+ * Make auto-remove and auto-clean aliases for the versions without -
+ (Closes: #274159)
+ * apt: Add autoremove and auto-remove commands
+ * changelog: Replace spelling reenable by re-enable everywhere.
+ Thanks to Lintian
+ * debian/control: Replace debian by Debian.
+ Thanks to Lintian
+ * debian/control: Drop the versioned python-apt conflict.
+ Thanks to Lintian
+ * debian/control: Remove XS- from Testsuite and bump Standards-Version.
+ Thanks to Lintian
+ * Set Acquire::Changelogs::URI::Origin::Tanglu for Tanglu changelogs
+ * Also add 'in combination with the other options.' to another error
+ * apt-cache(8): Drop the #versions >= #package names comparison
+ (Closes: #691281)
+ * apt-get: allow non-root --print-uris build-dep (Closes: #283400)
+ * doc/files.dbk: Improve documentation for {src,}pkgcache.bin
+ (Closes: #465551)
+ * update: Check if the cache could be opened, don't just assume it
+ (Closes: #756162)
+ * cachefile.cc: Do not ignore return value of pkgDepCache::Init()
+ * Add GetPriority(VerIterator) to pkgDepCache::Policy
+ * Document the general effect of the comma operator (Closes: #574939)
+ * When looking if Provides match, OR them with the normal patches
+ (Closes: #760868)
+ * install: If package already is the newest version, display version
+ (Closes: #315149)
+ * Make pkgCache::Priority() static, it does not need the instance
+ (Closes: #448627)
+ * Replace "extra" in "the following extra packages [...]" by "additional"
+ (Closes: #82430)
+ * Do not crash in 'apt show' for non-installed packages
+ * debian/NEWS: Mention new pinning algorithm added in 2.0~exp1
+
+ [ Yuri Kozlov ]
+ * Russian program translation update (Closes: 789709)
+
+ [ Guillem Jover ]
+ * po-fixups: fill Project-Id-Version and Encoding correctly (Closes: 612996)
+ * Do not set unhonored DPKG_NO_TSTP variable for dpkg (Closes: #765366)
+
+ [ Daniel Hartwig ]
+ * support setting a port for rsh:// in sources.list (Closes: 624727)
+ * replace direct calls to egrep with grep -E.
+ Thanks to David Weinehall for initial patch (Closes: 255577)
+
+ [ Luca Bruno ]
+ * Replace all "press enter" occurrences with "press [Enter]"
+ Thanks to Andre Felipe Machado for initial patch (Closes: 414848)
+
+ [ Jonathan Nieder ]
+ * document VERSION 2 (and 3) pre-install-pkgs hook interface (Closes: 627188)
+
+ [ Tomas Pospisek ]
+ * document APT::Periodic::RandomSleep.
+ Thanks to Chris Bainbridge and Kees Cook for initial text (Closes: 776380)
+
+ [ Johannes Schauer ]
+ * use a=experimental instead n=experimental in pin documentation
+ (Closes: 783343)
+
+ [ Kusanagi Kouichi ]
+ * Show full package records in apt-cache search -f (Closes: #660851)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 18 Aug 2015 11:15:52 +0200
+
+apt (1.1~exp8) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * merge unstable upload version 1.0.9.3
+ * Ensure /etc/apt/auth.conf has _apt:root owner
+ * Use sysconf(_SC_ARG_MAX) to find the size of Dpkg::MaxArgBytes
+ * Only support Translation-* that are listed in the {In,}Release file
+ * Call "Dequeue()" for items in AbortTransaction() to fix race
+ * prepare ABI for feature/socketpair
+ * Bump ABI to 4.15
+
+ [ David Kalnischkies ]
+ * re-enable support for -s (and co) in apt-get source (Closes: 742578)
+ * run acquire transactions only once
+ * aborted reverify restores file owner and permission
+ * test if TMPDIR is accessible before using (Closes: 765951)
+ * chown finished partial files earlier
+ * promote filesize to a hashstring
+
+ -- Michael Vogt <mvo@debian.org> Thu, 06 Nov 2014 10:01:21 +0100
+
+apt (1.1~exp7) experimental; urgency=medium
+
+ [ David Kalnischkies ]
+ * don't cleanup cdrom files in apt-get update (Closes: 765458)
+ * ignore Acquire::GzipIndexes for cdrom sources
+
+ -- David Kalnischkies <david@kalnischkies.de> Wed, 15 Oct 2014 20:12:15 +0200
+
+apt (1.1~exp6) experimental; urgency=medium
+
+ [ josch ]
+ * implement the updated build profile spec
+
+ [ Michael Vogt ]
+ * methods/rsh.cc: replace strcat with std::string (Closes: #76442)
+ * Add new configallowinsecurerepositories to the test framework
+
+ [ Guillem Jover ]
+ * Update Status field values handling
+
+ [ David Kalnischkies ]
+ * don't drop privileges if _apt has not enough rights
+ * check for available space, excluding root reserved blocks
+
+ -- Michael Vogt <mvo@debian.org> Wed, 15 Oct 2014 07:47:36 +0200
+
+apt (1.1~exp5) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * Only rename StatError files in AbortTransaction()
+ * Document Acquire{MaxReleaseFileSize,AllowInsecureRepositories,
+ AllowDowngradeToInsecureRepositories} and
+ --no-allow-insecure-repositories
+ * Fix backward compatibility of the new pkgAcquireMethod::DropPrivsOrDie()
+ * Change default of Acquire::AllowInsecureRepositories to "true"
+ so that this change is less disruptive, this will be switched
+ to "false" again after jessie
+
+ [ David Kalnischkies ]
+ * remove useless pdiff filename output (Closes: 764737)
+ * make --allow-insecure-repositories message an error
+ * display a warning for unsigned repos
+ * trusted=yes sources are secure, we just don't know why
+
+ -- Michael Vogt <mvo@debian.org> Mon, 13 Oct 2014 16:15:22 +0200
+
+apt (1.1~exp4) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * Merge sid version 1.0.9.2
+ * feature/acq-trans:
+ - Make apt-get update more transactional by keeping all data from
+ a sources.list line in partial/ until all data is good and only
+ then move it into lists/ in one step
+ - add new -o Debug::Acquire::Transaction=1 debug option
+ * feature/expected-size:
+ Do not download more data in the mehotds than expected if we know
+ the size. For the InRelease/Release/Release.gpg add new
+ Acquire::MaxReleaseFileSize that defaults to 10Mb for now
+ * Verify the the hashes of the downloaded compressed files early
+ * Only load unauthenticated data into our parsers when the user
+ explicitly asked for it via --allow-insecure-repositories
+ (Acquire::AllowInsecureRepositories)
+ * Print warning when trying to use unauthenticated repositories
+ * Use /var/empty as the homedir for _apt
+ * Revert making pkgAcquire::Item::DescURI() "const" to not break
+ API
+ * Do not allow going from a authenticated to unauthenticated repository
+ * Add missing "adduser" dependency (for the new _apt user)
+ Thanks to Russ Allbery (Closes: #763004)
+ * Test if TMPDIR is a directory in apt-key and if not unset it
+ * add early verification for the .diff/Index download
+ * Bump library version to libapt-pkg4.14
+ * Rework pkgAcqMeta{Index,Sig,ClearSig}::{Done,Failed]() for readability
+ * Ignore EINVAL from prctl(PR_SET_NO_NEW_PRIVS) (closes: 764066)
+
+ [ David Kalnischkies ]
+ * deprecate Pkg->Name in favor of Grp->Name
+ * drop stored StringItems in favor of in-memory mappings
+ * de-duplicate version strings in the cache
+ * fix progress output for (dist-)upgrade calculation
+ * move PCI::From* methods into CacheSetHelper class (Closes: 686221)
+ * add a (hidden) --quiet option for apt-key
+ * only create new trusted.gpg if directory is writeable
+ * support (multiple) arguments properly in apt-key
+ * set a primary-keyring only if we have access to it
+ * merge fragment keyrings in apt-key to avoid hitting gpg limits
+ (Closes: 733028)
+ * use apt-key adv (+ gnupg) instead of gpgv for verify
+ * support gnupg2 as drop-in replacement for gnupg
+ * allow to specify fingerprints in 'apt-key del'
+ * use only one --keyring in gpg interactions
+ * add and use 'apt-key verify' which prefers gpgv over gpg
+ * remove empty keyrings in trusted.gpg.d on upgrade
+ * store source name and version in binary cache
+ * allow fetcher setup without directory creation (Closes: 762898)
+ * cleanup partial directory of lists in apt-get clean (Closes: #762889)
+ * allow options between command and -- on commandline
+ * update symbols file
+ * support parsing of all hashes for pdiff
+ * ensure world-readability for trusted.gpg in postinst (Closes: 647001)
+ * ensure partial dirs are 0700 and owned by _apt:root
+ * use _apt:root only for partial directories
+ * display errortext for all Err
+ * set PR_SET_NO_NEW_PRIVS also if run as non-root
+
+ [ James McCoy ]
+ * ensure apt-key del handles 16-byte key ids (Closes: 754436)
+
+ [ Kenshi Muto ]
+ * Japanese program translation update (Closes: 763033)
+
+ [ Trần Ngọc Quân ]
+ * Set STRIP_FROM_PATH for doxygen
+
+ [ Mert Dirik ]
+ * Turkish program translation update (Closes: 763379)
+
+ [ Guillem Jover ]
+ * apt-get: Create the temporary downloaded changelog inside tmpdir
+
+ [ Miroslav Kure ]
+ * [l10n] Updated Czech translation of apt (Closes: #764055)
+
+ -- Michael Vogt <mvo@ubuntu.com> Wed, 08 Oct 2014 09:37:35 +0200
+
+apt (1.1~exp3) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * merged changes from debian/sid up to 1.0.9.1
+ * Make /var/lib/apt/lists and /var/cache/apt/archives owned
+ by the new _apt user
+ * Drop Privileges in the following acquire methods:
+ copy, http, https, ftp, gpgv, gzip/bzip2/lzma/xz
+ * DropPrivs: Improvements based on feedback from error@debian.org
+
+ [ Julian Andres Klode ]
+ * DropPriv: Really call seteuid and not setuid, and add more checks
+ * Use _apt as our unprivileged user name
+ * DropPrivs: Also check for saved set-user-ID and set-group-ID
+ * methods: Fail if we cannot drop privileges
+ * DropPrivs: Also check for saved set-user-ID and set-group-ID
+
+ -- Michael Vogt <mvo@debian.org> Wed, 24 Sep 2014 22:30:09 +0200
+