]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* doc/apt-get.8.xml:
[apt.git] / debian / rules
index a8bf88762e4fed8821d9f3f8bf480caf4cd94759..6a142e759a32a5f784b5bffc5ee6abb6879e8976 100755 (executable)
@@ -211,7 +211,7 @@ apt: build debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
        cp share/debian-archive.gpg debian/$@/usr/share/$@
-
+       cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
@@ -338,4 +338,4 @@ arch-build:
        mkdir -p debian/arch-build/apt-$(APT_DEBVER)
        tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)