+apt (0.8.16~exp12) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix segfault on pkg removal
+
+ [ David Kalnischkies ]
+ * apt-pkg/cacheiterators.h:
+ - return the correct version arch for all+foreign, too
+ * apt-pkg/packagemanager.cc:
+ - ignore breaks on not-installed versions while searching for
+ breakage loops as we don't have to avoid them
+ * debian/control:
+ - remove APT from the short descriptions as lintian doesn't like it
+ and it doesn't transport any information for a reader anyway
+ - apply typofixes by Pascal De Vuyst, thanks! (Closes: #652834, #652835)
+ * debian/rules:
+ - apply patch to enable usage of hardning CPPFLAGS and LDFLAGS by
+ Moritz Muehlenhoff, thanks! (Closes: #653504)
+ * methods/https.cc:
+ - use curls list append instead of appending Range and If-Range by hand
+ which generates malformed requests, thanks Mel Collins for the hint!
+ (Closes: #646381)
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Thu, 19 Jan 2012 23:43:03 +0100
+
+apt (0.8.16~exp11) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - redirect out/input of dpkg --assert-multi-arch to /dev/null
+ - if multi-arch is detected ensure that pkg:all is reported as pkg:all
+
+ -- Michael Vogt <mvo@debian.org> Thu, 19 Jan 2012 13:48:18 +0100
+
+apt (0.8.16~exp10) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/depcache.cc:
+ - implicit conflicts (for multiarch) are supposed to conflict
+ only with real packages, not with virtual providers
+ * apt-pkg/pkgcache.cc:
+ - ignore implicit conflicts on providers in AllTarget, too
+ * apt-pkg/deb/dpkgpm.cc:
+ - check if dpkg supports multiarch with --assert-multi-arch
+ and if it does be always explicit about the architecture
+ * apt-pkg/contrib/fileutl.h:
+ - store the offset in the internal fd before calculate size of
+ the zlib-handled file to jump back to this place again
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/fileutl.h:
+ - fix segfault triggered by the python-apt testsuite
+
+ -- Michael Vogt <mvo@debian.org> Wed, 18 Jan 2012 12:52:26 +0100
+
+apt (0.8.16~exp9) experimental; urgency=low
+
+ [ Julian Andres Klode ]
+ * apt-pkg/cdrom.cc:
+ - Accept .bz2, .xz files in addition to .gz files (Closes: #649451)
+
+ [ Michael Vogt ]
+ * apt-pkg/cdrom.cc:
+ - use aptconfiguration to get the supported compression types
+ * debian/control:
+ - bump debhelper build-dep to debhelper (>= 8.1.3~)
+ - set libapt-pkg-dev to multi-arch: same too
+ * g++ 4.7 fixes
+
+ [ Colin Watson ]
+ * Convert libapt-pkg4.12 and libapt-inst1.4 to Multi-Arch: same.
+
+ [ David Kalnischkies ]
+ * apt-pkg/cacheset.cc:
+ - make the cachesets real containers which can embedding any container
+ to be able to use the same interface regardless of set or list usage
+ - provide a {Package,Version}List similar to {Package,Version}Set
+ * cmdline/apt-{get,cache,mark}.cc:
+ - use Lists instead of Sets if input order should be preserved for
+ commands accepting lists of packages, e.g. policy (Closes: #625960)
+ * apt-pkg/depcache.cc:
+ - prefer native providers over foreigns even if the chain is foreign
+ * cmdline/apt-get.cc:
+ - ignore foreign architectures if we check if a provides has only one
+ resolver as it's basically the same for the user, so no need to choose
+ * cmdline/apt-config.cc:
+ - dump the APT::Compressor settings correctly and completely
+ * apt-pkg/contrib/fileutl.{h,cc}:
+ - implement a ModificationTime method for FileFd
+ - add a ReadLine method
+ - drop the explicit export of gz-compression handling
+ * apt-pkg/cdrom.cc:
+ - support InRelease files on cdrom
+
+ -- Michael Vogt <mvo@debian.org> Thu, 05 Jan 2012 20:26:31 +0100
+
apt (0.8.16~exp8) experimental; urgency=low
[ David Kalnischkies ]
+ * algorithms.cc:
+ - show a debug why a package was kept by ResolveByKeep()
* apt-pkg/packagemanager.cc:
- do not fail on unpacked packages in SmartUnPack, just don't
shedule them for unpack, but do all checks and configure them
+ - do not enter an endless loop for (essential) pre-dependency loops
+ * apt-pkg/contrib/sha2_internal.cc:
+ - use a pointer-union to peace gcc strict-aliasing warning
+ * apt-pkg/deb/deblistparser.cc:
+ - M-A: foreign packages provide for other archs, too
- -- David Kalnischkies <kalnischkies@gmail.com> Mon, 17 Oct 2011 11:21:21 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Thu, 03 Nov 2011 09:40:29 -0500
apt (0.8.16~exp7) experimental; urgency=low
-- Michael Vogt <mvo@debian.org> Wed, 29 Jun 2011 12:40:31 +0200
-apt (1.8.15.9+nmu1) unstable; urgency=low
+apt (0.8.15.10) UNRELEASEDunstable; urgency=low
[ David Kalnischkies ]
* algorithms.cc:
- show a debug why a package was kept by ResolveByKeep()
+ * doc/manpage-style.xml:
+ - put <brackets> around email addresses
+ * apt-pkg/aptconfiguration.cc:
+ - parse dpkg --print-foreign-architectures correctly in
+ case archs are separated by newline instead of space, too.
+ (Closes: #655590)
+ * doc/po/de.po:
+ - apply typo-fix from Michael Basse, thanks! (LP: #900770)
+
+ [ Chris Leick ]
+ * German manpage translation update
+ * doc/*.xml:
+ - find and fix a bunch of misspellings
+
+ [ Program translation updates ]
+ * Dutch (Jeroen Schot). Closes: #652230
+ * Slovak (Ivan Masar). Closes: #652985
+ * Russian (Yuri Kozlov). Closes: #654844
+ * Hungarian (Gabor Kelemen). Closes: #655238
- -- David Kalnischkies <kalnischkies@gmail.com> Mon, 17 Oct 2011 16:36:22 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Fri, 13 Jan 2012 17:30:36 +0100
apt (0.8.15.9) unstable; urgency=low