]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/acquire-worker.cc:
[apt.git] / debian / changelog
index 19c06b5e90c5e0e9a3a4a5120f2a9830b2c53185..65fd9e5901b84b3beb854352f8cf0882d345caf9 100644 (file)
@@ -9,6 +9,27 @@ apt (0.7.21) UNRELEASED; urgency=low
   * Documented all cron script related configuration items in 
     configure-index.
 
+  [ Michael Vogt ]
+  * apt-pkg/acquire.cc:
+    - make the max pipeline depth of the acquire queue configurable
+      via Acquire::Max-Pipeline-Depth
+  * apt-pkg/deb/dpkgpm.cc:
+    - add Dpkg::UseIoNice boolean option to run dpkg with ionice -c3
+      (off by default)
+    - send "dpkg-exec" message on the status fd when dpkg is run
+  * apt-pkg/algorithms.cc:
+    - consider recommends when making the scores for the problem 
+      resolver
+  * apt-pkg/acquire-worker.cc:
+    - show error details of failed methods
+  * apt-pkg/contrib/fileutl.cc:
+    - if a process aborts with signal, show signal number
+  * methods/http.cc:
+    - ignore SIGPIPE, we deal with EPIPE from write in 
+      HttpMethod::ServerDie() (LP: #385144)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 28 May 2009 17:51:42 +0200
+
   [ Michael Vogt ]
   * apt-pkg/indexcopy.cc:
     - support having CDs with no Packages file (just a Packages.gz)
@@ -46,12 +67,26 @@ apt (0.7.21) UNRELEASED; urgency=low
       state (LP: #322955)
   * methods/https.cc:
     - add Acquire::https::AllowRedirect support
+  * methods/gpgv.cc:
+    - properly check for expired and revoked keys (closes: #433091)
+  * fix problematic use of tolower() when calculating the version 
+    hash by using locale independant tolower_ascii() function. 
+    Thanks to M. Vefa Bicakci (LP: #80248)
+  * build fixes for g++-4.4
+  * cmdline/apt-mark:
+    - add "showauto" option to show automatically installed packages
 
   [ Dereck Wonnacott ]
   * apt-ftparchive might write corrupt Release files (LP: #46439)
   * Apply --important option to apt-cache depends (LP: #16947) 
   * Clarify the --help for 'purge' (LP: #243948)
 
+
+  [ Colin Watson ]
+  * cmdline/acqprogress.cc:
+    - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+      dlstatus messages on the status-fd (LP: #290234).
+
  -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 12 Sep 2008 11:34:24 +0200
 
 apt (0.7.20) unstable; urgency=low