-apt (0.8.5) UNRELEASED; urgency=low
+apt (0.8.11+wheezy) unstable; urgency=low
+ * apt-pkg/depcache.cc:
+ - add SetCandidateRelease() to set a candidate version and
+ the candidates of dependencies if needed to a specified
+ release (Closes: #572709)
+ * cmdline/apt-get.cc:
+ - if --print-uris is used don't setup downloader as we don't need
+ progress, lock nor the directories it would create otherwise
+ - show dependencies of essential packages which are going to remove
+ only if they cause the remove of this essential (Closes: #601961)
+ - keep not installed garbage packages uninstalled instead of showing
+ in the autoremove section and installing those (Closes: #604222)
+ - change pkg/release behavior to use the new SetCandidateRelease
+ so installing packages from experimental or backports is easier
+ - really do not show packages in the extra section if they were
+ requested on the commandline, e.g. with a modifier
+ * debian/control:
+ - add Vcs-Browser now that loggerhead works again (Closes: #511168)
+ * apt-pkg/contrib/fileutl.cc:
+ - add a RealFileExists method and check that your configuration files
+ are real files to avoid endless loops if not (Closes: #604401)
+ - ignore non-regular files in GetListOfFilesInDir (Closes: #594694)
+ * apt-pkg/contrib/weakptr.h:
+ - include stddefs.h to fix compile error (undefined NULL) with gcc-4.6
+ * methods/https.cc:
+ - fix CURLOPT_SSL_VERIFYHOST by really passing 2 to it if enabled
+ * deb/dpkgpm.cc:
+ - fix popen/fclose mismatch reported by cppcheck. Thanks to Petter
+ Reinholdtsen for report and patch! (Closes: #607803)
+ * doc/apt.conf.5.xml:
+ - fix multipl{y,e} spelling error reported by Jakub Wilk (Closes: #607636)
+ * apt-inst/contrib/extracttar.cc:
+ - let apt-utils work with encoded tar headers if uid/gid are large.
+ Thanks to Nobuhiro Hayashi for the patch! (Closes: #330162)
+ * apt-pkg/cacheiterator.h:
+ - do not segfault if cache is not build (Closes: #254770)
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Thu, 13 Jan 2011 23:19:03 +0100
+
+apt (0.8.10) unstable; urgency=low
+
+ [ Programs translations ]
+ * Czech by Miroslav Kure. Closes: #605107
+
+ [ Martin Pitt ]
+ * test/integration/test-compressed-indexes, test/test-indexes.sh:
+ - Explicitly disable compressed indexes at the start. This ensures that we
+ will actually test uncompressed indexes regardless of the internal
+ default value of Acquire::GzipIndexes.
+
+ [ David Kalnischkies ]
+ * apt-pkg/algorithms.cc:
+ - mark all installed packages first without auto installation in
+ a dist-upgrade to prefer upgrading packages instead of installing
+ new packages in versioned or-groups (Closes: #605394)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 30 Nov 2010 10:42:17 +0100
+
+apt (0.8.9) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Fix "typos" in French manpages translations. Thanks to
+ Cyril Brulebois for bashing me.
+ * Drop useless untranslatable sections from apt.8
+
+ [ Programs translations ]
+ * Slovenian update by Andrej Žnidaršič and Rosetta Slovenian team
+ * German update by Holger Wansing. Closes: #603619
+
+ [ David Kalnischkies ]
+ * apt-pkg/aptconfiguration.cc:
+ - evaluate Acquire::Languages= before LANG= (Closes: #602573)
+ * apt-pkg/orderlist.cc:
+ - try fixing before removing even if the fix is hidden in
+ a provides, hidden in the #590438 testcase
+ * apt-pkg/algorithms.cc:
+ - if the package was explicitly marked as ToRemove don't
+ consider it as a candidate for FixByInstall
+ * apt-pkg/depcache.cc:
+ - don't install previously not installed providers in a try
+ to statisfy a "Breaks: provides" dependency by upgrade
+ * cmdline/acqprogress.cc:
+ - don't ask the user for media change if quiet >= 2, stdout is not
+ a tty and assume-yes, force-yes or trivial-only option is set to
+ avoid cpu eating endless loops in unattended runs like apt.cron
+ (Closes: #602354, LP: #665580)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 18 Nov 2010 09:25:04 +0100
+
+apt (0.8.8) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/fileutl.cc:
+ - Add a FileFd::FileSize() method to get the size of the underlying
+ file and not the size of the content in the file as FileFd::Size()
+ does - the sizes can differ since the direct gzip integration
+ * methods/{gzip,bzip2}.cc:
+ - use FileSize() to determine if the file is invalid (Closes: #600852)
+ * apt-pkg/pkgcache.cc:
+ - fallback always to a suitable description (Closes: #601016)
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - ensure that history.log gets closed to avoid leaking a FD
+ (closes: #601649)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 28 Oct 2010 21:22:21 +0200
+
+apt (0.8.7) unstable; urgency=low
+
+ [ Manpages translations ]
+ * Typo fixed in French (extra "Z"). Thanks to Florentin Duneau.
+ * Another typo fixed in French ("Anfin"). Thanks to bubulle
+ * Wrong translation for "showauto" fixed. Thanks to Raphaël Hertzog
+ Closes: #599265
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - source /etc/default/locale (if available) so that the
+ apt-get update cron job fetches the right translated package
+ descriptions
+ * fix test failure on amd64
+ * apt-pkg/deb/debsystem.cc:
+ - fix issues with dir::state::status and dir::state::extended_states
+ when alternative rootdirs are used
+
+ [ Martin Pitt ]
+ * apt-pkg/deb/debindexfile.cc:
+ - Use FileFd::Size() instead of stat()ing the sources/binary/translations
+ indexes directly, so that we have transparent handling of gzipped
+ indexes.
+ * apt-pkg/contrib/fileutl.cc:
+ - Fix FileFd::Size() for gzipped files to give the size of the
+ uncompressed data. This fixes cache building progress going way
+ over 100%.
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/deblistparser.cc:
+ - support ArmHardFloat port in CompleteArch, thanks to Sebastian
+ Andrzej Siewior for the patch!
+ * doc/apt.ent:
+ - move some strings into apt-verbatim.ent to avoid showing them in
+ apt-doc.pot as they are untranslatable anyway (e.g. manpage references)
+ * doc/apt-verbatim.ent:
+ - change the codenames to reflect the situation after squeeze release
+ * doc/examples/apt-https-method-example.conf:
+ - apply various typo fixes by Olly Betts, thanks! (Closes: #600249)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 15 Oct 2010 18:16:10 +0200
+
+apt (0.8.6) unstable; urgency=low
+
+ [ Programs translations ]
+ * Vietnamese update by Clytie Siddall (Closes: #598489)
+ * Asturian update by Maacub (Closes: #599057)
+
+ [ David Kalnischkies ]
+ * cmdline/apt-cache.cc:
+ - use the TranslatedDescription for searching and not the first
+ available one as it is maybe not an expected language (Closes: #597925)
+ * apt-pkg/contrib/strutl.cc:
+ - add a space between number and unit as required by SI (Closes: #598352)
+ * apt-pkg/depcache.cc:
+ - do not check endpointer packages instead of only those which prevented
+ NeverAutoRemove settings from having an effect (Closes: #598452)
+ - do not remove packages which the user requested for installation
+ explicitly while satisfying other install requests (Closes: #598669)
+ * apt-pkg/packagemanager.cc:
+ - Add a space between period and 'Please' and unfuzzy all translations
+ * doc/po/de.po:
+ - remove the duplicated "angefertigt" in translation-holder string
+
+ -- Michael Vogt <mvo@debian.org> Mon, 04 Oct 2010 11:52:19 +0200
+
+apt (0.8.5) unstable; urgency=low
+
+ [ Manpages translations ]
+ * German (Chris Leick). Closes: #597163
+
+ [ Michael Vogt ]
* merged lp:~mvo/apt/conflicts-on-virtuals to better deal with
conflicts/breaks against virtual packages (LP: #614993)
- -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 15 Sep 2010 19:53:46 +0200
+ [ David Kalnischkies ]
+ * apt-pkg/policy.cc:
+ - support 100-pinning in Release file with ButAutomaticUpgrades
+ as requested by the backports crew (Closes: #596097)
+ * apt-pkg/deb/deblistparser.cc:
+ - overrule NotAutomatic in case of ButAutomaticUpgrades
+ * debian/apt.cron.daily:
+ - handle absolut directory paths correctly by loading directories
+ directly instead of building the paths on our own (Closes: #596421)
+ * debian/control:
+ - build-depend on docbook-xml to ensure that the xml DTDs are always
+ available on the buildds (Closes: #597145)
+ * buildlib/debiandoc.mak, buildlib/po4a_manpage.mak:
+ - ensure that the build fails if documentation building fails
+ * doc/po/fr.po:
+ - correct two syntax issues to ensure we can build fine
+
+ -- Michael Vogt <mvo@debian.org> Fri, 17 Sep 2010 22:05:06 +0200
apt (0.8.4) unstable; urgency=low