]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* doc/files.sgml:
[apt.git] / debian / changelog
index 2f262a3a9556c3d87291a841b067909e58e08479..07fc0845353cd244b55ff9b3fbaa177f94b6fb6e 100644 (file)
@@ -1,4 +1,4 @@
-apt (0.7.26~exp4) experimental; urgency=low
+apt (0.7.26~exp4) UNRELEASEDexperimental; urgency=low
 
   [ David Kalnischkies ]
   * apt-pkg/depcache.cc:
@@ -38,6 +38,14 @@ apt (0.7.26~exp4) experimental; urgency=low
     - be less strict and accept [option=value] as well
   * apt-pkg/contrib/configuration.cc:
     - error out if #clear directive has no argument
+  * doc/files.sgml:
+    - sync documentation with status quo, regarding files/directories in
+      use, extended_states and uri schemes.
+  * doc/cache.sgml:
+    - drop the file in favor of inplace documentation with doxygen
+  * apt-pkg/pkgcache.h:
+    - enhance the Groups ABI by providing a ID as the other structs does
+    - check also the size of the Group struct then checking for the others
 
   [ Jari Aalto ]
   * cmdline/apt-get.cc:
@@ -47,6 +55,29 @@ apt (0.7.26~exp4) experimental; urgency=low
     - modernize if-statements not to use 'x' (Closes: #577117)
     - replace backticks with POSIX $() (Closes: #577116)
 
+  [ Michael Vogt ]
+  * [ Abi break ] apt-pkg/acquire-item.{cc,h}:
+    - add "IsIndexFile" to constructor of pkgAcqFile so that it sends
+      the right cache control headers
+  * cmdline/apt-get.cc:
+    - fix crash when pkg.VersionList() is empty
+  * apt-pkg/depcache.cc:
+    - fix incorrect std::cout usage for debug output
+  * test/libapt/getlanguages_test.cc:
+    - Add test for Esperanto that has nocounty associated with them
+      (LP: #560956)
+
+  [ Julian Andres Klode ]
+  * apt-pkg/contrib/weakptr.h:
+    - add a class WeakPointable which allows one to register weak pointers to
+      an object which will be set to NULL when the object is deallocated.
+  * [ABI break] apt-pkg/acquire{-worker,-item,}.h:
+    - subclass pkgAcquire::{Worker,Item,ItemDesc} from WeakPointable.
+  * apt-pkg/pkgcache.cc:
+    - Merge fix from David to correct handling in single-arch environments.
+  * cmdline/apt-get.cc:
+    - Add apt-get markauto, showauto and unmarkauto commands.
+
  -- David Kalnischkies <kalnischkies@gmail.com>  Sat, 03 Apr 2010 14:58:39 +0200
 
 apt (0.7.26~exp3) experimental; urgency=low
@@ -114,9 +145,6 @@ apt (0.7.26~exp3) experimental; urgency=low
       Thanks to Chris Leick and Georg Koppen! (Closes: #574962)
   * apt-pkg/contrib/strutl.cc:
     - convert all toupper calls to tolower_ascii for a little speedup
-  * doc/files.sgml:
-    - sync documentation with status quo, regarding files/directories in
-      use, extended_states and uri schemes.
 
   [ Jean-Baptiste Lallement ]
   * apt-pkg/contrib/strutl.cc: