- remove the message size limit from ioprintf and strprintf
* apt-pkg/contrib/configuration.cc:
- add a more versatile Dump() method
+ - normalize a bit by replacing // and /./ with / in FindFile
+ - /dev/null is a special absolute path as it has no subdirectories
* apt-pkg/acquire-worker.cc:
- use Dump() to generate the configuration message for sending
* cmdline/apt-config.cc:
- implement --empty and --format option for dump
* apt-pkg/cdrom.cc:
- use Dump() to generate the configuration output
+ * apt-pkg/depcache.cc:
+ - clearly separate 'positive' and 'negative' dependencies and
+ their upgrade-resolution tries in MarkInstall and especially don't
+ treat Conflicts differently compared to Breaks here
+ - provider is only a possible solution if the provides has the right
+ version (or none as we have no versioned provides in debian) and not
+ if the version of the provider matches
+ * edsp/edspsystem.cc:
+ - check with RealFileExists for scenario file as otherwise a directory
+ like one provided with RootDir triggers the usage of EDSP
+ * debian/libapt-inst1.5.symbols:
+ - use the correct library name the symbols header
+ * apt-pkg/pkgcachegen.cc:
+ - check if NewDescription allocation has failed and error out accordingly
+ - check if we work on a valid description in IsDuplicateDescription as
+ we end up working on dangling pointers otherwise which segfaults on
+ s390x and ppc64 (Closes: #669427)
+ * apt-pkg/deb/deblistparser.cc:
+ - check length and containing chars for a given description md5sum
- -- David Kalnischkies <kalnischkies@gmail.com> Sun, 22 Apr 2012 13:01:04 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Sat, 05 May 2012 02:02:41 +0200
apt (0.9.2) unstable; urgency=low