-apt (0.7.12) UNRELEASED; urgency=low
+apt (0.7.15) UNRELEASED; urgency=low
+
+ [ Osamu Aoki ]
+ * Updated cron script to support backups by hardlinks and
+ verbose levels. All features turned off by default.
+ * Added more error handlings. Closes: #438803, #462734, #454989,
+ * Refactored condition structure to make download and upgrade performed
+ if only previous steps succeeded. Closes: #341970
+ * Documented all cron script related configuration items in
+ configure-index.
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - improve apt progress reporting, display trigger actions
+ * apt-pkg/depcache.cc:
+ - when checking for new important deps, skip critical ones
+ (LP: #236360)
+ * merge patch that enforces stricter https server certificate
+ checking (thanks to Arnaud Ebalard, closes: #485960)
+ * allow per-mirror specific https settings
+ (thanks to Arnaud Ebalard, closes: #485965)
+ * add doc/examples/apt-https-method-example.cof
+ (thanks to Arnaud Ebalard, closes: #485964)
+ * add DPkg::NoTriggers option so that applications that call
+ apt/aptitude (like the installer) defer trigger processing
+ (thanks to Joey Hess)
+ * document --install-recommends and --no-install-recommends
+ (thanks to Dereck Wonnacott, LP: #126180)
+ * fix various -Wall warnings
+ * make "apt-get build-dep" installed packages marked automatic
+ by default. This can be changed by setting the value of
+ APT::Get::Build-Dep-Automatic to false (thanks to Aaron
+ Haviland, closes: #44874, LP: #248268)
+ * apt-pkg/indexcopy.cc:
+ - support having CDs with no Packages file (just a Packages.gz)
+ by not forcing a verification on non-existing files
+ (LP: #255545)
+ * cmdline/apt-cache.cc:
+ - remove the gettext from a string that consists entirely
+ of variables (LP: #56792)
+ * doc/makefile:
+ - add examples/apt-https-method-example.conf
+ * apt-pkg/cacheiterators.h:
+ - add missing checks for Owner == 0 in end()
+ * apt-pkg/pkgcachegen.cc:
+ - do not add multiple identical descriptions for the same
+ language (closes: #400768)
+ * apt-pkg/packagemanager.cc, apt-pkg/deb/dpkgpm.cc:
+ - move the state file writting into the Go() implementation
+ of dpkgpm (closes: #498799)
+
+ [ Dereck Wonnacott ]
+ * apt-ftparchive might write corrupt Release files (LP: #46439)
+ * Apply --important option to apt-cache depends (LP: #16947)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
+
+apt (0.7.14) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Mark a message from dselect backend as translatable
+ Thanks to Frédéric Bothamy for the patch
+ Closes: #322470
+
+ [ Program translations ]
+ * Simplified Chinese updated. Closes: #473360
+ * Catalan fixes. Closes: #387141
+ * Typo fix in Greek translation. Closes: #479122
+ * French updated.
+ * Thai updated. Closes: #479313
+ * Italian updated. Closes: #479326
+ * Polish updated. Closes: #479342
+ * Bulgarian updated. Closes: #479379
+ * Finnish updated. Closes: #479403
+ * Korean updated. Closes: #479426
+ * Basque updated. Closes: #479452
+ * Vietnamese updated. Closes: #479748
+ * Russian updated. Closes: #479777
+ * Galician updated. Closes: #479792
+ * Portuguese updated. Closes: #479847
+ * Swedish updated. Closes: #479871
+ * Dutch updated. Closes: #480125
+ * Kurdish added. Closes: #480150
+ * Brazilian Portuguese updated. Closes: #480561
+ * Hungarian updated. Closes: #480662
+
+ [ Otavio Salvador ]
+ * Apply patch to avoid truncating of arbitrary files. Thanks to Bryan
+ Donlan <bdonlan@fushizen.net> for the patch. Closes: #482476
+ * Avoid using dbus if dbus-daemon isn't running. Closes: #438803
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - apply patch based on the ideas of Francesco Poli for better
+ behavior when the cache can not be locked (closes: #459344)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 28 May 2008 15:19:12 +0200
+
+apt (0.7.13) unstable; urgency=low
+
+ [ Otavio Salvador ]
+ * Add missing build-depends back from build-depends-indep field.
+ Closes: #478231
+ * Make cron script quiet if cache is locked. Thanks to Ted Percival
+ <ted@midg3t.net> for the patch. Closes: #459344
+ * Add timeout support for https. Thanks to Andrew Martens
+ <andrew.martens@strangeloopnetworks.com> for the patch.
+
+ [ Goswin von Brederlow ]
+ * Add support for --no-download on apt-get update. Closes: #478517
+
+ [ Program translations ]
+ - Vietnamese updated. Closes: #479008
+
+ -- Otavio Salvador <otavio@debian.org> Fri, 02 May 2008 14:46:00 -0300
+
+apt (0.7.12) unstable; urgency=low
[ Michael Vogt ]
* cmdline/apt-key:
starting the upate to hit the mirrors less hard
* doc/apt_preferences.5.xml:
- fix typo
+ * added debian/README.source
[ Christian Perrier ]
* Fix typos in manpages. Thanks to Daniel Leidert for the fixes
- Polish updated. Closes: #469581
- Slovak updated. Closes: #471341
- French updated.
+ - Bulgarian updated. Closes: #448492
+ - Galician updated. Closes: #476839
[ Daniel Burrows ]
* apt-pkg/depcache.cc:
- Patch MarkInstall to follow currently satisfied Recommends even
if they aren't "new", so that we automatically force upgrades
when the version of a Recommends has been tightened. (Closes: #470115)
+ - Enable more complete debugging information when Debug::pkgAutoRemove
+ is set.
* apt-pkg/contrib/configuration.cc
- Lift the 1024-byte limit on lines in configuration files.
(Closes: #473710, #473874)
* apt-pkg/contrib/strutl.cc:
- Lift the 64000-byte limit on individual messages parsed by ReadMessages.
(Closes: #474065)
+ * debian/rules:
+ - Add missing Build-Depends-Indep on xsltproc, docbook-xsl, and xmlto.
- -- Michael Vogt <mvo@debian.org> Thu, 10 Jan 2008 12:06:12 +0100
+ -- Daniel Burrows <dburrows@debian.org> Sat, 26 Apr 2008 12:24:35 -0700
apt (0.7.11) unstable; urgency=critical