]> git.saurik.com Git - apt.git/blobdiff - debian/rules
merged from debian-sid
[apt.git] / debian / rules
index f587b141a83827db89e8e0596c0cd4d8d0a3d4d0..e4ecfbdd73c24cd278496bca2d25ae4eef99b6fc 100755 (executable)
@@ -131,7 +131,7 @@ clean:
        rm -rf build
 
        # Add here commands to clean up after the build process.
        rm -rf build
 
        # Add here commands to clean up after the build process.
-       dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
+       dh_clean debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
 
 binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
 
 binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
@@ -213,8 +213,10 @@ apt: build build-doc debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/debian-archive.gpg debian/$@/usr/share/$@
+       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+       sed 's/^_//' share/apt-auth-failure.note > debian/$@/usr/share/$@/apt-auth-failure.note
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+       cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        # copy lintian override
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        # copy lintian override
@@ -225,6 +227,10 @@ apt: build build-doc debian/shlibs.local
        rm -f build/po/*.pot
        rm -f po/*.pot
 
        rm -f build/po/*.pot
        rm -f po/*.pot
 
+       # move the mirror failure script in place
+       mv debian/$@/usr/bin/apt-report-mirror-failure \
+          debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ 
        dh_installcron -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ 
        dh_installcron -p$@