]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
eipp: provide the internal planer as an external one
[apt.git] / debian / tests / run-tests
index 233c5a386b1f80790dd87810a38f85b9ffa16ddf..11139e3cd1816fcdcf5e91578c9c28901ab4c79a 100644 (file)
@@ -2,17 +2,22 @@
 
 set -e
 
-# auto-package-test is very unhappy if stuff it writen to stderr
-exec 2> apt-stderr.log
-
 # we need the buildin webserver for the tests
 if [ ! -e environment.mak ]; then
-    ./configure
+    make startup
 fi
 make -C test/interactive-helper/
 
-# run against the installed apt
+# run tests against the installed apt, use "env -i" to ensure
+# the host env does not pollute our environment
+env -i \
+APT_INTEGRATION_TESTS_SOURCE_DIR=$(pwd) \
 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
 APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
+APT_INTEGRATION_TESTS_INTERNAL_SOLVER=/usr/lib/apt/solvers/apt \
+APT_INTEGRATION_TESTS_DUMP_SOLVER=/usr/lib/apt/solvers/dump \
+APT_INTEGRATION_TESTS_INTERNAL_PLANER=/usr/lib/apt/planers/apt \
 APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
-./test/integration/run-tests
+APT_INTEGRATION_TESTS_LIBRARY_PATH=/dev/null/does/not/exist \
+./test/integration/run-tests -q