]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
Merge remote-tracking branch 'donkult/debian/experimental' into debian/experimental
[apt.git] / debian / tests / run-tests
index ebea3b200c7059986efb6e118fb8bedcb627fc10..9d7c484fce66f68673c8166144bd0ef33d20498e 100644 (file)
@@ -8,11 +8,13 @@ if [ ! -e environment.mak ]; then
 fi
 make -C test/interactive-helper/
 
-# run against the installed apt
+# run tests against the installed apt, use "env -i" to ensure
+# the host env does not pollute our environment
+env -i \
 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
 APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
 APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
-APT_INTEGRATION_TESTS_INTERNAL_SOLVER_DIR=/usr/lib/apt/solvers \
+APT_INTEGRATION_TESTS_INTERNAL_SOLVER=/usr/lib/apt/solvers/apt \
 APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
 APT_INTEGRATION_TESTS_LIBRARY_PATH=/dev/null/does/not/exist \
 ./test/integration/run-tests