]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
- cmdline/apt-extracttemplates.cc: likewise;
[apt.git] / debian / changelog
index 43f9ad7b733bf13451014e161a33e91638cf1d46..ad887b29ee6bc551cb60c0e80a5ab11be868dccd 100644 (file)
@@ -14,22 +14,66 @@ apt (0.7.7) UNRELEASED; urgency=low
     - merged dpkg-log branch, this lets you specify a 
       Dir::Log::Terminal file to log dpkg output to
       (ABI break)
+    - fix parse error when dpkg sends unexpected data
   * merged apt--sha256 branch to fully support the new
     sha256 checksums in the Packages and Release files
     (ABI break)
+  * apt-pkg/pkgcachegen.cc:
+    - increase default mmap size
+  * tests/local-repo:
+    - added local repository testcase
+  * apt-pkg/acquire.cc:
+    - increase MaxPipeDepth for the internal worker<->method
+      communication to 1000 for the debtorrent backend
+  * make apt build with g++ 4.3
+  * fix missing SetExecClose() call when the status-fd is used
+  * debian/apt.cron.daily:
+    - move unattended-upgrade before apt-get autoclean
+  * fix "purge" commandline argument, closes: #133421
+    (thanks to Julien Danjou for the patch)
+  * cmdline/apt-get.cc:
+    - do not change the auto-installed information if a package
+      is reinstalled
+  * apt-pkg/acquire-item.cc:
+    - fix crash in diff acquire code
+  * cmdline/apt-mark:
+    - Fix chmoding after have renamed the extended-states file (LP: #140019)
+      (thanks to Laurent Bigonville)
   
   [ Program translations ]
     - French updated
     - Basque updated. Closes: #436425
     - Fix the zh_CN translator's name in debian/changelog for 0.7.2
       Closes: #423272
+    - Vietnamese updated. Closes: #440611
+    - Danish updated. Closes: #441102
+    - Thai added. Closes: #442833
 
   [ Otavio Salvador ]
   * Add hash support to copy method. Thanks Anders Kaseorg by the patch
     (closes: #436055)
   * Reset curl options and timestamp between downloaded files. Thanks to
     Ryan Murray <rmurray@debian.org> for the patch (closes: #437150)
-
+  * Add support to apt-key to export keys to stdout. Thanks to "Dwayne
+    C. Litzenberger" <dlitz@dlitz.net> for the patch (closes: #441942)
+  * Fix compilation warnings:
+    - apt-pkg/indexfile.cc: conversion from string constant to 'char*';
+    - apt-pkg/acquire-item.cc: likewise;
+    - apt-pkg/cdrom.cc: '%lu' expects 'long unsigned int', but argument
+      has type 'size_t';
+    - apt-pkg/deb/dpkgpm.cc: initialization order and conversion from
+      string constant to 'char*';
+    - methods/gpgv.cc: conversion from string constant to 'char*';
+    - methods/ftp.cc: likewise;
+    - cmdline/apt-extracttemplates.cc: likewise;
+
+  [ Ian Jackson ]
+  * dpkg-triggers: Deal properly with new package states.
+
+  [ Colin Watson ]
+  * apt-pkg/contrib/mmap.cc:
+    - don't fail if msync() returns > 0
  -- Otavio Salvador <otavio@debian.org>  Mon, 06 Aug 2007 10:44:53 -0300
 
 apt (0.7.6) unstable; urgency=low