# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.38 2002/10/16 05:58:16 jgg Exp $
+# $Id: rules,v 1.41 2002/11/09 20:21:54 doogie Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
export DH_COMPAT=2
+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+ confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+ confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
# See below
-include build/environment.mak
+-include build/environment.mak
# Default rule
build:
dh_testdir
-mkdir build
cp COPYING debian/copyright
- (cd build; ../configure)
+ifneq ($(wildcard /usr/share/misc/config.sub),)
+ cp -a /usr/share/misc/config.sub buildlib/config.sub
+ echo Updating buildlib/config.sub
+endif
+ifneq ($(wildcard /usr/share/misc/config.guess),)
+ cp -a /usr/share/misc/config.guess buildlib/config.guess
+ echo Updating buildlib/config.guess
+endif
+ (cd build; ../configure $(confflags))
touch $@
build/build-stamp: build/configure-stamp
# Add here commands to clean up after the build process.
-$(MAKE) clean
-$(MAKE) distclean
- dh_clean
+ dh_clean debian/copyright
binary-indep: libapt-pkg-doc
# Build architecture-independent files here.