+apt (0.8.11) UNRELEASED; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/depcache.cc:
+ - add SetCandidateRelease() to set a candidate version and
+ the candidates of dependencies if needed to a specified
+ release (Closes: #572709)
+ - allow conflicts in the same group again (Closes: #612099)
+ * cmdline/apt-get.cc:
+ - if --print-uris is used don't setup downloader as we don't need
+ progress, lock nor the directories it would create otherwise
+ - show dependencies of essential packages which are going to remove
+ only if they cause the remove of this essential (Closes: #601961)
+ - keep not installed garbage packages uninstalled instead of showing
+ in the autoremove section and installing those (Closes: #604222)
+ - change pkg/release behavior to use the new SetCandidateRelease
+ so installing packages from experimental or backports is easier
+ - really do not show packages in the extra section if they were
+ requested on the commandline, e.g. with a modifier (Closes: #184730)
+ - always do removes first and set not installed remove packages
+ on hold to prevent temporary installation later (Closes: #549968)
+ * debian/control:
+ - add Vcs-Browser now that loggerhead works again (Closes: #511168)
+ - depend on debhelper 7 to raise compat level
+ - depend on dpkg-dev (>= 1.15.8) to have c++ symbol mangling
+ * apt-pkg/contrib/fileutl.cc:
+ - add a RealFileExists method and check that your configuration files
+ are real files to avoid endless loops if not (Closes: #604401)
+ - ignore non-regular files in GetListOfFilesInDir (Closes: #594694)
+ * apt-pkg/contrib/weakptr.h:
+ - include stddefs.h to fix compile error (undefined NULL) with gcc-4.6
+ * methods/https.cc:
+ - fix CURLOPT_SSL_VERIFYHOST by really passing 2 to it if enabled
+ * deb/dpkgpm.cc:
+ - fix popen/fclose mismatch reported by cppcheck. Thanks to Petter
+ Reinholdtsen for report and patch! (Closes: #607803)
+ * doc/apt.conf.5.xml:
+ - fix multipl{y,e} spelling error reported by Jakub Wilk (Closes: #607636)
+ * apt-inst/contrib/extracttar.cc:
+ - let apt-utils work with encoded tar headers if uid/gid are large.
+ Thanks to Nobuhiro Hayashi for the patch! (Closes: #330162)
+ * apt-pkg/cacheiterator.h:
+ - do not segfault if cache is not build (Closes: #254770)
+ * doc/apt-get.8.xml:
+ - remove duplicated mentioning of --install-recommends
+ * doc/sources.list.5.xml:
+ - remove obsolete references to non-us (Closes: #594495)
+ * debian/rules:
+ - use -- instead of deprecated -u for dh_gencontrol
+ - remove shlibs.local creation and usage
+ - show differences in the symbol files, but never fail
+ * pre-build.sh:
+ - remove as it is not needed for a working 'bzr bd'
+ * debian/{apt,apt-utils}.symbols:
+ - ship experimental unmangled c++ symbol files
+ * methods/rred.cc:
+ - operate optional on gzip compressed pdiffs
+ * apt-pkg/acquire-item.cc:
+ - don't uncompress downloaded pdiff files before feeding it to rred
+ - try downloading clearsigned InRelease before trying Release.gpg
+ - change the internal handling of Extensions in pkgAcqIndex
+ - add a special uncompressed compression type to prefer those files
+ - download and use i18n/Index to choose which Translations to download
+ * cmdline/apt-key:
+ - don't set trustdb-name as non-root so 'list' and 'finger'
+ can be used without being root (Closes: #393005, #592107)
+ * apt-pkg/deb/deblistparser.cc:
+ - rewrite LoadReleaseInfo to cope with clearsigned Releasefiles
+ * ftparchive/writer.cc:
+ - add config option to search for more patterns in release command
+ - include Index files by default in the Release file
+ * methods/{gzip,bzip}.cc:
+ - print a good error message if FileSize() is zero
+ * apt-pkg/aptconfiguration.cc:
+ - remove the inbuilt Translation files whitelist
+ * cmdline/apt-cache.cc:
+ - remove not implemented 'apt-cache add' command
+ * doc/apt-cache.8.xml:
+ - describe reality as apt-cache just queries and doesn't manipulate
+ the caches. Thanks to Enrico Zini for spotting it! (Closes: #612009)
+ * apt-pkg/algorithms.cc:
+ - mark pseudo packages of installed all packages as configured
+ in the simulation as we don't call configure for these packages
+ * apt-pkg/pkgcachegen.cc:
+ - in multiarch, let :all packages conflict with :any packages
+ with a different version to be sure
+ * apt-pkg/contrib/error.cc:
+ - remove 400 char size limit of error messages (LP: #365611)
+
+ [ Michael Vogt ]
+ * methods/http.cc:
+ - do not hang if Acquire::http::ProxyAutoDetect can not be
+ executed or returns no data (LP: #654393)
+ * debian/apt.conf.autoremove:
+ - never autoremove the GNU/Hurd kernel (closes: #588423), thanks
+ to Guillem Jover
+ * apt-pkg/cdrom.cc, apt-pkg/init.cc, methods/cdrom.cc:
+ - use /media/cdrom as default mountoint (closes: #611569)
+
+ [ Martin Pitt ]
+ * test/integration/test-compressed-indexes, test/test-indexes.sh:
+ - Explicitly disable compressed indexes at the start. This ensures that we
+ will actually test uncompressed indexes regardless of the internal
+ default value of Acquire::GzipIndexes.
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Mon, 07 Feb 2011 21:42:06 +0100
+
+apt (0.8.10.3) unstable; urgency=low
+
+ [ Programs translations ]
+ * po/es.po: Updated, plus fixes encoding issues and fixes two fuzzy
+ strings, thanks to Javier Fernandez-Sanguino (closes: #610692)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 25 Jan 2011 11:51:42 +0100
+
+apt (0.8.10.2) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * ftparchive/apt-ftparchive.cc:
+ - fix endless loop for multiple TranslationsWriters
+
+ -- Michael Vogt <mvo@debian.org> Tue, 25 Jan 2011 10:26:15 +0100
+
+apt (0.8.10.1) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Fix encoding for Slovenian translation. PO file switched
+ to UTF-8. Closes: #609957
+
+ [ Julian Andres Klode ]
+ * cmdline/apt-cache.cc: Create an error for apt-cache depends
+ if packages could not found (LP: #647045)
+
+ [ Programs translations ]
+ * Spanish update by Javier Fernández-Sanguino Peña. Closes: #607145
+
+ [ Manpages translations ]
+ * Correct a typo and an error in French manpages translation.
+ Closes: # 607170
+
+ -- Michael Vogt <mvo@debian.org> Mon, 17 Jan 2011 13:41:04 +0100
+
+apt (0.8.10) unstable; urgency=low
+
+ [ Programs translations ]
+ * Czech by Miroslav Kure. Closes: #605107
+
+ [ Martin Pitt ]
+ * test/integration/test-compressed-indexes, test/test-indexes.sh:
+ - Explicitly disable compressed indexes at the start. This ensures that we
+ will actually test uncompressed indexes regardless of the internal
+ default value of Acquire::GzipIndexes.
+
+ [ David Kalnischkies ]
+ * apt-pkg/algorithms.cc:
+ - mark all installed packages first without auto installation in
+ a dist-upgrade to prefer upgrading packages instead of installing
+ new packages in versioned or-groups (Closes: #605394)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 30 Nov 2010 10:42:17 +0100
+
+apt (0.8.9) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Fix "typos" in French manpages translations. Thanks to
+ Cyril Brulebois for bashing me.
+ * Drop useless untranslatable sections from apt.8
+
+ [ Programs translations ]
+ * Slovenian update by Andrej Žnidaršič and Rosetta Slovenian team
+ * German update by Holger Wansing. Closes: #603619
+
+ [ David Kalnischkies ]
+ * apt-pkg/aptconfiguration.cc:
+ - evaluate Acquire::Languages= before LANG= (Closes: #602573)
+ * apt-pkg/orderlist.cc:
+ - try fixing before removing even if the fix is hidden in
+ a provides, hidden in the #590438 testcase
+ * apt-pkg/algorithms.cc:
+ - if the package was explicitly marked as ToRemove don't
+ consider it as a candidate for FixByInstall
+ * apt-pkg/depcache.cc:
+ - don't install previously not installed providers in a try
+ to statisfy a "Breaks: provides" dependency by upgrade
+ * cmdline/acqprogress.cc:
+ - don't ask the user for media change if quiet >= 2, stdout is not
+ a tty and assume-yes, force-yes or trivial-only option is set to
+ avoid cpu eating endless loops in unattended runs like apt.cron
+ (Closes: #602354, LP: #665580)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 18 Nov 2010 09:25:04 +0100
+
+apt (0.8.8) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/fileutl.cc:
+ - Add a FileFd::FileSize() method to get the size of the underlying
+ file and not the size of the content in the file as FileFd::Size()
+ does - the sizes can differ since the direct gzip integration
+ * methods/{gzip,bzip2}.cc:
+ - use FileSize() to determine if the file is invalid (Closes: #600852)
+ * apt-pkg/pkgcache.cc:
+ - fallback always to a suitable description (Closes: #601016)
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - ensure that history.log gets closed to avoid leaking a FD
+ (closes: #601649)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 28 Oct 2010 21:22:21 +0200
+
+apt (0.8.7) unstable; urgency=low
+
+ [ Manpages translations ]
+ * Typo fixed in French (extra "Z"). Thanks to Florentin Duneau.
+ * Another typo fixed in French ("Anfin"). Thanks to bubulle
+ * Wrong translation for "showauto" fixed. Thanks to Raphaël Hertzog
+ Closes: #599265
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - source /etc/default/locale (if available) so that the
+ apt-get update cron job fetches the right translated package
+ descriptions
+ * fix test failure on amd64
+ * apt-pkg/deb/debsystem.cc:
+ - fix issues with dir::state::status and dir::state::extended_states
+ when alternative rootdirs are used
+
+ [ Martin Pitt ]
+ * apt-pkg/deb/debindexfile.cc:
+ - Use FileFd::Size() instead of stat()ing the sources/binary/translations
+ indexes directly, so that we have transparent handling of gzipped
+ indexes.
+ * apt-pkg/contrib/fileutl.cc:
+ - Fix FileFd::Size() for gzipped files to give the size of the
+ uncompressed data. This fixes cache building progress going way
+ over 100%.
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/deblistparser.cc:
+ - support ArmHardFloat port in CompleteArch, thanks to Sebastian
+ Andrzej Siewior for the patch!
+ * doc/apt.ent:
+ - move some strings into apt-verbatim.ent to avoid showing them in
+ apt-doc.pot as they are untranslatable anyway (e.g. manpage references)
+ * doc/apt-verbatim.ent:
+ - change the codenames to reflect the situation after squeeze release
+ * doc/examples/apt-https-method-example.conf:
+ - apply various typo fixes by Olly Betts, thanks! (Closes: #600249)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 15 Oct 2010 18:16:10 +0200
+
+apt (0.8.6) unstable; urgency=low
+
+ [ Programs translations ]
+ * Vietnamese update by Clytie Siddall (Closes: #598489)
+ * Asturian update by Maacub (Closes: #599057)
+
+ [ David Kalnischkies ]
+ * cmdline/apt-cache.cc:
+ - use the TranslatedDescription for searching and not the first
+ available one as it is maybe not an expected language (Closes: #597925)
+ * apt-pkg/contrib/strutl.cc:
+ - add a space between number and unit as required by SI (Closes: #598352)
+ * apt-pkg/depcache.cc:
+ - do not check endpointer packages instead of only those which prevented
+ NeverAutoRemove settings from having an effect (Closes: #598452)
+ - do not remove packages which the user requested for installation
+ explicitly while satisfying other install requests (Closes: #598669)
+ * apt-pkg/packagemanager.cc:
+ - Add a space between period and 'Please' and unfuzzy all translations
+ * doc/po/de.po:
+ - remove the duplicated "angefertigt" in translation-holder string
+
+ -- Michael Vogt <mvo@debian.org> Mon, 04 Oct 2010 11:52:19 +0200
+
+apt (0.8.5) unstable; urgency=low
+
+ [ Manpages translations ]
+ * German (Chris Leick). Closes: #597163
+
+ [ Michael Vogt ]
+ * merged lp:~mvo/apt/conflicts-on-virtuals to better deal with
+ conflicts/breaks against virtual packages (LP: #614993)
+
+ [ David Kalnischkies ]
+ * apt-pkg/policy.cc:
+ - support 100-pinning in Release file with ButAutomaticUpgrades
+ as requested by the backports crew (Closes: #596097)
+ * apt-pkg/deb/deblistparser.cc:
+ - overrule NotAutomatic in case of ButAutomaticUpgrades
+ * debian/apt.cron.daily:
+ - handle absolut directory paths correctly by loading directories
+ directly instead of building the paths on our own (Closes: #596421)
+ * debian/control:
+ - build-depend on docbook-xml to ensure that the xml DTDs are always
+ available on the buildds (Closes: #597145)
+ * buildlib/debiandoc.mak, buildlib/po4a_manpage.mak:
+ - ensure that the build fails if documentation building fails
+ * doc/po/fr.po:
+ - correct two syntax issues to ensure we can build fine
+
+ -- Michael Vogt <mvo@debian.org> Fri, 17 Sep 2010 22:05:06 +0200
+
+apt (0.8.4) unstable; urgency=low
+
+ [ Michael vogt ]
+ * ftparchive/writer.cc:
+ - write out {Files,Checksum-Sha1,Checksum-Sha256} only if
+ available LP: #633967. Thanks to Colin Watson
+ * apt-pkg/contrib/cdromutl.cc:
+ - if apt-cdrom is used on writable media (like usb-sticks), do
+ not use the root directory to identify the medium (as all
+ changes there change the ident id). Use the .disk directory
+ instead
+
+ [ David Kalnischkies ]
+ * ftparchive/writer.cc:
+ - null the valid string instead of the date if Valid-Until is not set
+ * apt-pkg/acquire-item.cc:
+ - use also unsigned Release files again (Closes: #596189)
+
+ [ Christian Perrier ]
+ * Fix missing space after dot in a message from apt-pkg
+ Translations unfuzzied. Thanks to Holger Wansing.
+
+ -- Michael Vogt <mvo@debian.org> Fri, 10 Sep 2010 20:45:15 +0200
+
+apt (0.8.3) unstable; urgency=low
+
+ [ Programs translations ]
+ * German (Holger Wansing). Closes: #596141
+
+ [ Manpages translations ]
+ * Japanese (KURASAWA Nozomu). Closes: #595862
+
+ [ Michael Vogt ]
+ * apt-pkg/indexcopy.cc:
+ - only use trusted.gpg.d directory if it exists
+ - do not replace /dev/null when running in APT::CDROM::NoAct
+ mode (LP: #612666), thanks to Colin Watson
+
+ [ David Kalnischkies ]
+ * ftparchive/apt-ftparchive.cc:
+ - ensure that BinDirectory as well as Tree settings get
+ the correct default FileMode setting (Closes: #595922)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 07 Sep 2010 15:28:41 +0200
+
+apt (0.8.2) unstable; urgency=low
+
+ [ Manpages translations ]
+ * Spanish (Omar Campagne). Closes: #595557
+
+ [ David Kalnischkies ]
+ * apt-pkg/versionmatch.cc:
+ - do not accept 'Pin: origin "' (missing closing ") as a valid
+ way to pin a local archive: either "" or none…
+ * apt-pkg/deb/dpkgpm.cc:
+ - create Dir::Log if needed to support /var/log as tmpfs or similar,
+ inspired by Thomas Bechtold, thanks! (Closes: #523919, LP: #220239)
+ * apt-pkg/indexcopy.cc:
+ - support really still the APT::GPGV::TrustedKeyring setting,
+ as it breaks d-i badly otherwise (Closes: #595428)
+ * cmdline/apt-key:
+ - support also Dir::Etc::Trusted so that apt-key works in the same
+ way as the library part which works with the trusted files
+ * methods/{gzip,bzip2}.cc:
+ - empty files can never be valid archives (Closes: #595691)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 06 Sep 2010 18:10:06 +0200
+
+apt (0.8.1) unstable; urgency=low
+
+ [ Programs translations ]
+ * Thai (Theppitak Karoonboonyanan). Closes: #592695
+ * Russian (Yuri Kozlov). Closes: #594232
+ * Slovak (Ivan Masár). Closes: #594255
+ * Swedish (Daniel Nylander). Closes: #594241
+ * Japanese (Kenshi Muto, Osamu Aoki). Closes: #594265
+ * Italian (Milo Casagrande). Closes: #594238
+ * Asturian (maacub). Closes: #594303
+ * Simplified Chinese (Aron Xu). Closes: #594458
+ * Bulgarian (Damyan Ivanov). Closes: #594627
+ * Portuguese (Miguel Figueiredo). Closes: #594668
+ * Korean (Changwoo Ryu). Closes: #594809
+ * Norwegian Bokmål (Hans Nordhaug). Closes: #595182
+ * Danish (Joe Hansen). Closes: #595176
+ * Catalan (Agustí Grau). Closes: #595234
+
+ [ Christian Perrier ]
+ * Fix spelling error in cmdline/apt-get.cc. Thanks to Osamu Aoki
+ Closes: #594211
+
+ [ Manpages translations ]
+ * Portuguese (Américo Monteiro)
+
+ [ David Kalnischkies ]
+ * cmdline/apt-cache.cc:
+ - show in madison command again also source packages (LP: #614589)
+ - remove useless GetInitialize method
+ * cmdline/apt-get.cc:
+ - remove direct calls of ReadMainList and use the wrapper instead
+ to protect us from useless re-reads and two-times notice display
+ - remove death code by removing unused GetInitialize
+ * apt-pkg/depcache.cc:
+ - now that apt-get purge works on 'rc' packages let the MarkDelete
+ pass this purge forward to the non-pseudo package for pseudos
+ * apt-pkg/contrib/fileutl.cc:
+ - apply SilentlyIgnore also on files without an extension
+ * apt-pkg/contrib/configuration.cc:
+ - fix autoremove by using correct config-option name and
+ don't make faulty assumptions in error handling (Closes: #594689)
+ * apt-pkg/versionmatch.cc:
+ - let the pin origin actually work as advertised in the manpage
+ which means "" are optional and pinning a local archive does
+ work - even if it is a non-flat archive (Closes: #594435)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 03 Sep 2010 18:36:11 +0200
+
+apt (0.8.0) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * merge of the debian-expermental-ma branch
+ * refresh po/pot files in doc/ and po/
+
+ [ Programs translations ]
+ * Swedish (Daniel Nylander). Closes: #592366
+ * French (Christian Perrier)
+
+ [ Manpages translations ]
+ * French (Christian Perrier)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 24 Aug 2010 16:32:19 +0200
+
apt (0.8.0~pre2) experimental; urgency=low
[ David Kalnischkies ]