]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* Update apt-get(8) to reflect the fact that APT::Get::...
[apt.git] / debian / rules
index f90defa26e8fd6eb4717587b4b016ff182d368c0..0ba6efab8c363684161faabafe739335688bff15 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.55 2003/09/22 14:36:20 mdz Exp $
+# $Id: rules,v 1.67 2004/05/08 19:57:31 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -27,12 +27,19 @@ endif
 # See below
 -include build/environment.mak
 
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+  export CXXFLAGS = -O0 -g -Wall
+else
+  export CXXFLAGS = -O2 -g -Wall
+endif
+
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild -us -uc
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -53,7 +60,7 @@ endif
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
 .PHONY: configure.in
 configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
 else
 configure.in:
 endif
@@ -99,7 +106,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && ../configure $(confflags)
+       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -210,9 +217,9 @@ apt: build debian/shlibs.local
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
+       dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -268,7 +275,7 @@ apt-utils: build debian/shlibs.local
        dh_fixperms -p$@
        dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_installdeb -p$@
-       LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -306,14 +313,15 @@ binary: binary-indep binary-arch
 # edit configure.in
 # debian/rules cvs-build
 
+CVS_BUILDDIR=apt-$(APT_DEBVER)
+CVS_ROOT=$(shell cat CVS/Root)
+CVS_MODULE=$(shell cat CVS/Repository)
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update
-       $(MAKE) startup
-       $(MAKE) doc
-       tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
-               (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-       (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+       mkdir -p debian/cvs-build
+       (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
+       $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
+       (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
 
 cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)