-apt (0.9.14.2) UNRELEASED; urgency=low
+apt (1.0.4) UNRELEASED; urgency=medium
+
+ [ Michael Vogt ]
+ * Implement CacheDB for source packages in apt-ftparchive
+ * apt-private/acqprogress.cc: reset color in apt update
+ * Show progress in run-tests
+ * Never parse Version/Architecture tags in a Translation-$lang file
+ * Show upgradable packages after apt update (Closes: 748389)
+ * Fix various errors found by clang -fsanitize=address
+ * Fix various errors foudn by clang scan-build
+ * Show unauthenticated warning for source packages as well (Closes: #749795)
+ * Add compat mode for old (32bit FileSize) CacheDB (LP: #1274466)
+ * cmdline/apt-helper.cc: use less generic description/short-description
+ in apt-helper download
+ * add pkgSrcRecords::Next() to step through all the pkgSrcRecords
+ (thanks to Helmut Grohne)
+
+ [ David Kalnischkies ]
+ * initialize Verify in second pkgAcqIndex constructor
+ * consistently fail if Smart* packagemanager actions fail
+ * fix tight loop detection and temporary removes
+ * if Resolver fails, do not continue even if not broken
+ * check exit status of external solvers
+ * do not revert candidate for protected packages (Closes: 745046)
+ * support Acquire::GzipIndexes in dumpavail (Closes: 742835)
+
+ [ Stefano Zacchiroli ]
+ * EDSP doc: fix typo in Request stanza description
+ * EDSP: bump protocol version to 0.5
+ * EDSP: add Architecture(s) multi-arch fields to the Request stanza
+ * EDSP: add Source field to Package stanzas
+ * EDSP: add APT-Release field to Package stanzas
+
+ [ Sebastian Schmidt ]
+ * fix screen width detection for apt/apt-get lists (Closes: 748430, 747942)
+
+ [ Milo Casagrande ]
+ * Italian program translation update (Closes: 750009)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 10 Jun 2014 14:55:05 +0200
+
+apt (1.0.3) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * reduce delta to ubuntu
+ * provide support for vendor specific config files
+ * debian/apt-doc.docs: remove README.MultiArch
+ * Fix missing ScreenWidth check in apt.cc
+ * Only do openpty() if both stdin/stdout are terminals (Closes: 746434)
+
+ [ David Kalnischkies ]
+ * add a README for vendor information
+ * remove outdated README.MultiArch
+ * build http request in a stringstream
+ * enforce LFS for partial files in https range requests
+ * handle pkgnames shorter than modifiers (Closes: 744940)
+ * allow vendors to install configuration files
+
+ [ John Ogness ]
+ * properly undo CD-ROM mount in all error cases
+
+ [ Mahyuddin Ramli ]
+ * add vendor information for BlankOn (Closes: 743595)
+
+ [ Adam Conrad ]
+ * fix FileFd::Size bitswap on big-endian architectures (Closes: 745866)
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po: Update one new string
+
+ -- Michael Vogt <mvo@debian.org> Mon, 05 May 2014 14:03:15 +0200
+
+apt (1.0.2) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * fix apt list output for pkgs in dpkg ^rc state
+ * Notice the user about "apt list -a" when only a single hit if found
+ * fix test-failure in adt
+ * apt-private/acqprogress.cc: fix output when ctrl-c is hit during
+ apt update (LP: #1310548, closes: #744297)
+ * Fix option name DPkg::Progress-Fancy in apt.8 manpage
+ (LP: #1310506)
+
+ [ David Kalnischkies ]
+ * don't double-count seeks in FileFd::Skip for bzip/xz
+ * deal with umask only if we really need to for mkstemp
+ * consider priorities only for downloadable pkgs in resolver
+ * force fancy progressbar redraw on window size change
+ * clear HitEof flag in FileFd::Seek
+ * use Google C++ Testing Framework for libapt tests
+ * support dist-upgrade options in full-upgrade
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (624t): Update translation
+
+ [ Theppitak Karoonboonyanan ]
+ * Updated Thai program translation (closes: #745120)
+
+ [ James McCoy ]
+ * Consistently use Dpkg::Progress* in documentation (Closes: 745452)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 25 Apr 2014 13:15:03 +0200
+
+apt (1.0.1) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * Fix crash in "apt list" when a sources.list file is unreable
+ (Closes: 743413)
+ * make apt search case-insensitive by default
+ * Fix possible race when stunnel/aptwebserver create their PID files
+ in the tests
+ * Fix insecure file permissions when using FileFd with OpenMode::Atomic
+ (LP: #1304657)
+
+ [ Julian Andres Klode ]
+ * Version the Breaks/Replaces for sun-java{5,6}-jdk (LP: #1302736)
+ (Closes: #743616)
+ * Add versioned openjdk-6-jdk breaks
+
+ [ Josef Vitu ]
+ * apt: Minor typo in 'apt' man page (closes: #743657)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 10 Apr 2014 09:48:56 +0200
+
+apt (1.0) unstable; urgency=low
+
+ The "Happy birthday and 10000b years in the making" release
+
+ [ Julian Andres Klode ]
+ * apt-inst: Do not try to create a substring of an empty string in
+ error reporting (LP: #1288718)
+
+ [ Beatrice Torracca ]
+ * Italian manpages translation update (Closes: 741867)
+
+ [ Kenshi Muto ]
+ * Japanese programs translation update (Closes: 742255)
+
+ [ David Kalnischkies ]
+ * continue reading in xz even if it outputs nothing
+ * only consider versioned kernel packages in autoremove (Closes: 741962)
+ * correct some reported typos in /etc/cron.daily/apt (Closes: 702016)
+ * ensure proper teardown in dpkg error cases (Closes: 738969)
+ * update symbols file to include new symbols from 0.9.16
+ * do IsInstallOk call in MarkInstall unconditionally
+ * discard candidates via IsInstallOk to allow override (Closes: 740750)
+
+ [ Michael Vogt ]
+ * install apt binary
+ * add apt.8.xml manpage
+ * make fancy-progress fg/bg color configurable via something like
+ Dpkg::Progress-Fancy::Progress-{bg,fg}="%1b[30m"
+ (thanks to Tim Wasser for the suggestion)
+ * Add progressbar to "Dpkg::Progress-Fancy"
+ * fix documentation for APT::Periodic::MaxSize "0" (closes: #740551)
+ * Use mkstemp() in apt-extracttemplaes (closes: #741627)
+ * Add new Debug::RunScripts debug option
+ * do not crash on SIGPIPE in pkgDPkgPM::RunScriptsWithPkgs()
+ * enable DPkg::Progress-Fancy by default when "apt" is used
+ * refresh po/pot and unfuzzy apt-extracttemplate manpage change
+ * remove no longer needed apt.7 page
+ * install "apt" binary by default
+ * add sun-java{5,6}-jdk to breaks/replaces as they provided a
+ "apt" binary as well
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (623t): Update Vietnamese translation
+ * debian: Add default compress option to xz
+
+ -- Michael Vogt <mvo@debian.org> Tue, 01 Apr 2014 15:48:46 +0200
+
+apt (0.9.16.1) unstable; urgency=medium
+
+ [ Chris Leick ]
+ * Updated German doc translation
+
+ [ Julian Andres Klode ]
+ * Fix handling of autoclosing for compressed files (Closes: #741685)
+
+ -- Julian Andres Klode <jak@debian.org> Sat, 15 Mar 2014 18:05:25 +0100
+
+apt (0.9.16) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * add hashsum support in apt-helper download-file and
+ add more tests
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (624t): Update Vietnamese translation
+
+ [ David Kalnischkies ]
+ * propagate a negative score point along breaks/conflicts
+ * check version before adding scores in resolver
+ * autogenerate makefile for vendor system
+ * add default and override handling for Cnf::FindVector
+ * support DEB_BUILD_PROFILES and -P for build profiles
+ * do not configure already unpacked packages needlessly (Closes: 740843)
+ * if mountpoint has a ".disk" directory it is mounted
+ * no error for non-existing mountpoints in MountCdrom
+ * apt-cdrom ident shouldn't be interactive (Closes: 740673)
+ * support very long mtab entries in mountpoint discovery
+ * msgstr with elipses need three dots
+ * cmdline parsing: apt-config is not apt-cdrom
+ * use a configurable list of versioned kernel packages
+ * support kfreebsd and hurd in the kernel hook
+ * add ".*-{kernel,modules}-$KERVER" matcher for hook
+ * ensure that a dot is a dot in the hook
+ * use liblzma-dev to provide xz/lzma support
+ * use the pretty fullname of a pkg as download desciption
+
+ [ Johannes Schauer ]
+ * implement BuildProfileSpec support as dpkg has in 1.17.2 (Closes: 661537)
+
+ [ Wojciech Górski ]
+ * fix polish --install-suggests text in apt-get manpage (Closes: 741056)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 14 Mar 2014 09:45:05 +0100
+
+apt (0.9.15.5) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * vendor/tanglu/makefile: add missing clean/sources.list
+ * run the acquire tests with the new apt-helper binary, this
+ fixes the autopkgtest failures
+
+ [ Martin Pitt ]
+ * Fix autopkgtest missing dependencies and locale (closes: #739988)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 28 Feb 2014 08:44:25 +0100
+
+apt (0.9.15.4) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * remove auto-generated apt-key and sources.list on clean (closes: 739749)
+ * add testcase for Bug#718329
+ * various fixes for ADT failures
+
+ [ Jon Severinsson ]
+ * add apt-vendor information for tanglu
+
+ [ Guillem Jover ]
+ * ExtractTar: Allow an empty decompressor program
+ * DebFile: Refactor ExtractTarMember() out from ExtractArchive()
+ * Add support for data.tar, control.tar and control.tar.xz
+ * debian: Add debDebFile::ExtractTarMember to the symbols file
+ * Fix typos in documentation (codespell)
+
+ -- Michael Vogt <mvo@debian.org> Sun, 23 Feb 2014 00:27:12 +0100
+
+apt (0.9.15.3) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * disable https->http redirects in libcurl, thanks to Julien Cristau
+ * ADT: use "Restrictions: allow-stderr and avoid apt-stderr.log in
+ debian/tests/run-tests
+ * test/integration/test-bug-723705-tagfile-truncates-fields:
+ - fix autopkgtest failure
+ * add missing canNotFindFnmatch/showFnmatchSelection
+ (for the next ABI break)
+ * disable fnmatch() matching from the commandline
+ * merge testcase for the autoremove feature from the ubuntu branch
+
+ [ David Kalnischkies ]
+ * do not recommend dselect in apt-get manpage (Closes: 617625)
+ * report https download start only if we really get it
+ * allow http protocol to switch to https
+ * do not compress .xhtml files and remove junk files (Closes: 738933)
+ * simplify code some more to make reddit happy
+ * update symbols file with hints from the buildlogs
+
+ -- Michael Vogt <mvo@debian.org> Thu, 20 Feb 2014 14:42:39 +0100
+
+apt (0.9.15.2) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * move isatty() check into InitOutput()
+ * Use a APT::VersionSet instead of a VersionList
+ (closes: #738103)
+
+ [ David Kalnischkies ]
+ * simplify code to make compilers happy
+ * update libapt-pkg.symbols file
+ * bump Standards-Version to 3.9.5 (no changes needed)
+ * do not use an empty APT_CONFIG environment variable
+ * always cleanup patchfiles at the end of rred call
+ * use VersionSet in download to handle repeats (Closes: 738103)
+ * use utimes instead of utimensat/futimens (Closes: 738567)
+
+ [ John Ogness ]
+ * apt-cdrom should succeed if any drive succeeds (Closes: 728153)
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (621t): Update and review
+
+ -- Michael Vogt <mvo@debian.org> Thu, 13 Feb 2014 09:50:04 +0100
+
+apt (0.9.15.1) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * use gpg --homedir instead of explicit file placement
+ * use svg in doxygen and ensure dot is around for it
+ * pkgTagFile: if we have seen the end, do not try to see more
+ * restart debSrcRecordParsers only if needed
+ * discard impossible candidates in MarkInstall (Closes: #735967)
+
+ [ Chris Leick ]
+ * update german manpage translation
+ * Trivian unfuzzies of the German po4a translation
+
+ [ Michael Vogt ]
+ * fix apt-get download truncation (closes: #736962)
+ * do not crash if VF.File()/VF.File().Archive() is NULL
+ * show "status" in apt list last to be more awk friendly
+ (thanks to Axel Beckert)
+ * Fix multiarch package upgrade issue
+ * add test for Suite with path
+
+ [ Colin Watson ]
+ * multicompress with externals sets wrong file modes (Closes: 737130)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 06 Feb 2014 18:09:19 +0100
+
+apt (0.9.15) unstable; urgency=low
+
+ * upload version from debian/experimental to unstable
+
+ -- Michael Vogt <mvo@debian.org> Sat, 25 Jan 2014 21:57:00 +0100
+
+apt (0.9.14.3~exp5) experimental; urgency=medium
+
+ [ Anthony Towns ]
+ * methods/rred: minor robustness improvements
+
+ [ Michael Vogt ]
+ * make "apt-mark help" shows all commands
+ * make "apt show" output more user friendly
+ * add "apt full-upgrade" and tweak "apt upgrade"
+ * set APT::Sources::Use-Deb822=false until the format
+ is fully finalized
+
+ -- Michael Vogt <mvo@debian.org> Fri, 24 Jan 2014 23:21:04 +0100
+
+apt (0.9.14.3~exp4) experimental; urgency=medium
+
+ * implement deb822 suggestions by Anthony Towns and Julian Andres Klode:
+ - add Description tag for deb822 sources
+ - add support for Enabled: no in deb822 sources.list
+ - add support for multiple URIs in deb822 style sources.list
+ - add support for multipl types in one line
+ * add integration test for apt search and apt show
+ * do not ignore ioctl(TIOCSCTTY) errors
+
+ -- Michael Vogt <mvo@debian.org> Wed, 22 Jan 2014 18:59:07 +0100
+
+apt (0.9.14.3~exp3) experimental; urgency=low
+
+ * implement deb822 suggestions by donkult (thanks!):
+ - rename "Dist" to "Suites"
+ - rename "Section" to "Sections"
+ - rename "Architectures-Delete" to "Architectures-Remove"
+ - rename "Uri" to "URI"
+ * add "apt list --manual-installed"
+ * add "apt upgrade --dist"
+ * add "apt purge"
+ * flock() the file edited in "apt edit-sources"
+ * apt-private/private-show.cc:
+ - do not show Description-lang: header
+ * reword apt !isatty() warning
+ * add missing integration test for "apt list" and fix bugs
+ found by it
+
+ -- Michael Vogt <mvo@debian.org> Sat, 18 Jan 2014 21:09:24 +0100
+
+apt (0.9.14.3~exp2) experimental; urgency=medium
+
+ [ Julian Andres Klode ]
+ * debian/rules: Call dh_makeshlibs for 'apt'
+
+ [ Anthony Towns ]
+ * reimplement rred to allow applying all the diffs in a single pass
+ * correct IndexDiff vs DiffIndex in Debug output
+
+ [ David Kalnischkies ]
+ * reenable unlimited pdiff files download
+ * integrate Anthonys rred with POC for client-side merge
+
+ [ Michael Vogt ]
+ * document deb822 style sources.list in sources.list(5)
+ * rename "Dist:" in deb822 style sources.list to "Suite:"
+ * rename URL to Uri in deb822-sources
+ * support multiple "Suite:" entries in deb822 style sources.list:
+ "Suite: stable testing unstable"
+
+ -- Michael Vogt <mvo@debian.org> Thu, 16 Jan 2014 21:43:22 +0100
+
+apt (0.9.14.3~exp1) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * add support for "deb822" style sources.list format and add
+ APT::Sources::Use-Deb822 to support disabling it
+
+ [ David Kalnischkies ]
+ * implement POC client-side merging of pdiffs via apt-file
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po(617t): Update Vietnamese translation
+
+ -- Michael Vogt <mvo@debian.org> Sun, 05 Jan 2014 15:13:32 +0100
+
+apt (0.9.14.2) unstable; urgency=low
[ Joe Hansen ]
* Danish translation update. Closes: #732166
[ Peter Green ]
* add apt-vendor for raspbian. Closes: #732749
+
+ [ Thomas Bechtold ]
+ * apt-pkg/contrib/gpgv.cc: use /tmp as fallback dir if the
+ directory from $TMPDIR is not available (closes: #728500)
[ Michael Vogt ]
* vendor/getinfo:
- fix ubuntu-codename
* vendor/steamos/*:
- add steamos support
-
- -- Christian Perrier <bubulle@debian.org> Sun, 15 Dec 2013 08:43:06 +0100
+ * bugfix/bts731738-fancy-progess:
+ - fix terminal size issues with e.g. "less" when "APT::Progress-Fancy=1"
+ is used (closes: #731738)
+ * feature/policy-parser-bts732746:
+ - allow more flexibility in /etc/apt/preferences, e.g. comment only
+ sections (closes: #732746)
+ * move TMPDIR handling into GetTempDir() and use that instead of
+ getenv("TMPDIR")
+ * update apt-key net-update and add integration test with the buildin
+ apt webserver
+ * run autopkgtest against the installed apt
+
+ -- Michael Vogt <mvo@debian.org> Sun, 29 Dec 2013 16:41:16 +0100
apt (0.9.14.1) unstable; urgency=medium