]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Changed ld_library_path
[apt.git] / debian / rules
index 7cc06d8fce1902398c4323d5dc2c6359487ecdd3..8f72514dcf8f6d7899a86281fcb6d801e87dea35 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.32 2001/04/17 06:46:13 jgg Exp $
+# $Id: rules,v 1.35 2001/08/03 04:58:10 jgg Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -89,6 +89,7 @@ configure: configure.in
 build/configure-stamp: configure
        dh_testdir
        -mkdir build
+       cp COPYING debian/copyright
        (cd build; ../configure)
        touch $@
 
@@ -244,7 +245,7 @@ apt-utils: build debian/shlibs.local
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       LD_LIBRARY_PATH=`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+       LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_md5sums -p$@