]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
debian/rules: add hardening=+all
[apt.git] / debian / apt.postinst
index a538abde988bdbaf07c685d77c00e5b672df4330..deb422aa5d3920bfaf25e21b1f42e8abfd0e6f90 100755 (executable)
@@ -15,6 +15,15 @@ set -e
 
 case "$1" in
     configure)
+       if dpkg --compare-versions "$2" lt 1.1~exp4; then
+           # apt-key before 0.9.10 could leave empty keyrings around
+           find /etc/apt/trusted.gpg.d/ -name '*.gpg' | while read keyring; do
+               if ! test -s "$keyring"; then
+                   rm -f "$keyring"
+               fi
+           done
+       fi
+
        if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then
            # we are using tmpfiles for both
            rm -f /etc/apt/trustdb.gpg