+apt (0.9.13~exp1) UNRELEASED; urgency=low
+
+ * Improve the API for APT::Upgrade::Upgrade()
+ * Re-add "Calculating upgrade..." message
+ * move upgrade releated code into upgrade.{cc,h}
+ * Move ListUpdate/AquireUpdate into update.{cc,h}
+ * Add new apt-pkg/install-progress.h with APT::Progress::PackageManager
+ progress reporting classes
+ * Move the status-fd progress reporting out of the pkgDPkgPM class
+ and into PackageManagerProgressFd
+ * Fix reading dpkg --status-fd on reinstalls
+ * Add new APT::Status-deb822-Fd progress output
+ * add Acquire::http::Proxy-Auto-Detect to the apt.conf.5 manpage
+ (closes: 726597)
+ * Fix detection when multiarch packages are reported by dpkg as
+ disappeared Packages
+ * test/integration/run-tests: output the failed test names
+ * Code Cleanup in pkgDPkgPM
+ * prepare next ABI via #if (APT_PKG_MAJOR >= 4 && APT_PKG_MINOR >= 13)
+ * add new pid_t ExecFork(std::set<int> KeepFDs)
+ * Avoid flickering when "apt-get -o DpkgPM::Progress-Fancy=1" is use
+
+ -- Michael Vogt <mvo@debian.org> Thu, 31 Oct 2013 23:25:59 +0100
+
+apt (0.9.12.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * do not send pkgname:arch over the APT::Status-Fd to not break
+ clients (closes: 726156). A new APT::Status-deb822-Fd will be
+ used to fix this.
+ * add integration tests for APT::Status-Fd
+ * add missing _() around the new "Progress" string
+
+ [ David Kalnischkies ]
+ * fix progress-segfault in case of dpkg errors/prompts (Closes: 726047)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 15 Oct 2013 18:25:51 +0200
+
+apt (0.9.12) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Fix typo in apt-private/private-show.cc. Thanks to Benjamin
+ Keresa. Closes: #724073
+
+ [ Mark Hymers ]
+ * fix libapt-inst for >2G debs (closes: #725483)
+
+ [ David Kalnischkies ]
+ * don't strip :any from dependencies in single-arch (Closes: 723586)
+ * pkg from only trusted sources keeps being trusted (Closes: 617690)
+ * compression-neutral message for missing data.tar member (Closes: 722710)
+ * print-uris prints regardless of quiet-level again (Closes: 722207)
+ * retry without partial data after a 416 response (Closes: 710924)
+ * replace "filesize - 1" trick in http with proper 416 handling
+ * fix partial (206 and 416) support in https
+ * handle complete responses to https range requests (Closes: 617643, 667699)
+ (LP: 1157943)
+ * don't consider holds for autoremoval (Closes: 724995)
+ * put fetch errors in 'source' on our errorstack
+ * use pkgAcqArchive in 'download' for proper errors
+ * fix lzma-support detection via xz binary
+ * do not ++ on erased package pointers in autoremove
+
+ [ Michael Vogt ]
+ * Add new "apt-get upgrade --with-new-pkgs" option (and add man-page for it).
+ So "apt-get upgrade --with-new-pkgs" will pull in new dependencies but
+ never remove packages
+ * Rename "--dpkg-progress" to "--show-progress" and document it in
+ apt-get.8. This will show global install progress information in the
+ terminal.
+ * Fix status-fd progress calculation for certain multi-arch install/upgrade
+ situations
+ * add new -o DpkgPM::Progress-Fancy for nicer dpkg progress output
+ on vt100+ terminals
+ * fix libapt-inst for >2G debs (closes: #725483), thanks to Mark Hymers
+ * debian/apt.postinst: use --compare-versions lt instead of lt-nl,
+ to ensure the apt-auto-removal file is correctly create,
+ thanks to Ben Hutchings
+ * update Uploaders to match recent uploaders better
+ * Set the default "Acquire::PDiffs::FileLimit" to 20. If the amount
+ of pdiffs is bigger things tend to get slower. Set
+ Acquire::PDiffs::FileLimit "0";
+ in /etc/apt/apt.conf to get the old behavior back.
+
+ -- Michael Vogt <mvo@debian.org> Wed, 09 Oct 2013 22:39:41 +0200
+
+apt (0.9.11.4) unstable; urgency=low
+
+ [ Oskari Saarenmaa ]
+ * don't truncate 100 char long paths in tar extraction.
+ Thanks to Mika Eloranta for the testcase! (Closes: #689582)
+
+ [ David Kalnischkies ]
+ * do not trust FileFd::Eof() in pkgTagFile::Fill()
+ Thanks to Cyril Brulebois (Closes: 723705)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 20 Sep 2013 16:12:07 +0200
+
apt (0.9.11.3) unstable; urgency=low
[ Michael Vogt ]