]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* merged the apt-breaks-iwj branch
[apt.git] / debian / rules
index 333d4ad5b802fe935a26e768d2c3b36ccaf7592f..68302daff23ea64f90ed22d065dace57c761ce86 100755 (executable)
@@ -38,7 +38,7 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -210,8 +210,8 @@ apt: build debian/shlibs.local
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
-       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
-
+       cp share/debian-archive.gpg debian/$@/usr/share/$@
+       cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        # make rosetta happy and remove pot files in po/ (but leave stuff