]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* dpkg-triggers: Deal properly with new package states.
[apt.git] / debian / changelog
index d7f844f5c3a320ffb100a3ab342617beedf2805d..e2c0e53036f5c416def99a8643e025bd202cfddd 100644 (file)
@@ -1,7 +1,32 @@
 apt (0.7.7) UNRELEASED; urgency=low
 
+  [ Michael Vogt ]
   * apt-inst/contrib/extracttar.cc:
-    - fix fd leak for zero size files 
+    - fix fd leak for zero size files (thanks to Bill Broadley for
+      reporting this bug)
+  * apt-pkg/acquire-item.cc:
+    - remove zero size files on I-M-S hit
+  * methods/https.cc:
+    - only send LastModified if we actually have one
+    - send range request with if-range 
+    - delete failed downloads
+  * apt-pkg/deb/dpkgpm.{cc,h}:
+    - merged dpkg-log branch, this lets you specify a 
+      Dir::Log::Terminal file to log dpkg output to
+      (ABI break)
+  * merged apt--sha256 branch to fully support the new
+    sha256 checksums in the Packages and Release files
+    (ABI break)
+  * apt-pkg/pkgcachegen.cc:
+    - increase default mmap size
+  * tests/local-repo:
+    - added local repository testcase
+  * apt-pkg/acquire.cc:
+    - increase MaxPipeDepth for the internal worker<->method
+      communication to 1000 for the debtorrent backend
+
+  [ Ian Jackson ]
+  * dpkg-triggers: Deal properly with new package states.
 
  -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 02 Aug 2007 11:55:54 +0200