]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
remove Dir:: scope limit of RootDir in the documentation
[apt.git] / debian / apt.postinst
index b8f3edbe595e9ebae2fef8405ad2d839fce2b6c3..b0a5da7d85d7cb5c5ba46c65a15b63fc83be6f0c 100755 (executable)
@@ -15,13 +15,17 @@ set -e
 
 case "$1" in
     configure)
-       if dpkg --compare-versions "$2" lt 1.0.7; then
+       if dpkg --compare-versions "$2" lt 1.1~exp4; then
            # apt-key before 0.9.10 could leave empty keyrings around
            find /etc/apt/trusted.gpg.d/ -name '*.gpg' | while read keyring; do
                if ! test -s "$keyring"; then
                    rm -f "$keyring"
                fi
            done
+           # apt-key before 0.9.8.2 could create 0600 trusted.gpg file
+           if test -e /etc/apt/trusted.gpg ; then
+               chmod -f 0644 /etc/apt/trusted.gpg || true
+           fi
        fi
 
        if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then