apt (0.9.4) UNRELEASED; urgency=low
[ David Kalnischkies ]
+ * methods/http.cc:
+ - after many years of pointless discussions disable http/1.1 pipelining
+ by default as many webservers and proxies seem to be unable to conform
+ to specification must's (rfc2616 section 8.1.2.2) (LP: #996151)
+ - add spaces around PACKAGE_VERSION to fix FTBFS with -std=c++11
* apt-pkg/pkgcachegen.cc:
- make IsDuplicatedDescription static so that it is really private
as we don't need a symbol for it as it is not in a header
are no longer build in the same target as the manpages
* apt-pkg/acquire-methods.cc:
- factor out into private Dequeue() to fix access to deleted pointer
+ * apt-pkg/contrib/fileutl.cc:
+ - ensure that we close compressed fds, wait for forks and such even if
+ the FileFd itself is set to not autoclose the given Fd
+ * cmdline/apt-get.cc:
+ - use the host architecture, not the build architecture for matching
+ of [architecture restrictions] in Build-Depends (Closes: #672927)
[ Raphael Geissert ]
* apt-pkg/acquire*.cc:
in the method the redirection occured in (Closes: #668111)
* methods/http.cc:
- forbid redirects to change protocol
+ * methods/mirror.cc:
+ - generate an equal sign also for the first arch (Closes: #669142)
+
+
+ [ Marius Vollmer ]
+ * apt-pkg/algorithms.cc:
+ - fix memory leak of Flags in pkgSimulate by a proper destructor
-- David Kalnischkies <kalnischkies@gmail.com> Fri, 11 May 2012 23:26:59 +0200