-apt (0.8.15.3) UNRELEASED; urgency=low
+apt (0.8.15.11) UNRELEASED; urgency=low
+
+ * Fix typo in apt-get(8). Closes: #664833
+
+ -- Christian Perrier <bubulle@debian.org> Tue, 27 Mar 2012 20:31:38 +0200
+
+apt (0.8.15.10) unstable; urgency=high
+
+ [ David Kalnischkies ]
+ * algorithms.cc:
+ - show a debug why a package was kept by ResolveByKeep()
+ * doc/manpage-style.xml:
+ - put <brackets> around email addresses
+ * doc/po/de.po:
+ - apply typo-fix from Michael Basse, thanks! (LP: #900770)
+ * apt-pkg/acquire-item.cc:
+ - remove 'old' InRelease file if we can't get a new one before
+ proceeding with Release.gpg to avoid the false impression of a still
+ trusted repository by a (still present) old InRelease file.
+ Thanks to Simon Ruderich for reporting this issue! (CVE-2012-0214)
+
+ [ Chris Leick ]
+ * German manpage translation update
+ * doc/*.xml:
+ - find and fix a bunch of misspellings
+
+ [ Program translation updates ]
+ * Dutch (Jeroen Schot). Closes: #652230
+ * Slovak (Ivan Masar). Closes: #652985
+ * Russian (Yuri Kozlov). Closes: #654844
+ * Hungarian (Gabor Kelemen). Closes: #655238
+ * Polish (Michał Kułach). Closes: #656908
+ * Danish (Joe Hansen). Closes: #658643
+ * French: replace "étiquetage" by "épinglage" for "pinning"
+
+ [ Michael Vogt ]
+ * merged patch from lp:~uusijani/apt/uusi-branch:
+ Correct fi translation for hash sum mismatches (lp:420403)
+ Thanks to Jani Uusitalo
+
+ -- Michael Vogt <mvo@debian.org> Tue, 06 Mar 2012 14:14:26 +0100
+
+apt (0.8.15.9) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * Symbol file update
+ * doc/apt-get.8.xml:
+ - change wording of autoremove description as suggested
+ by Robert Simmons, thanks! (Closes: #641490)
+ * apt-pkg/deb/dpkgpm.cc:
+ - use std::vector instead of fixed size arrays to store args and
+ multiarch-packagename strings
+ - load the dpkg base arguments only one time and reuse them later
+ * cmdline/apt-get.cc:
+ - follow Provides in the evaluation of saving candidates, too, for
+ statisfying garbage package dependencies (Closes: #640590)
+ * apt-pkg/algorithms.cc:
+ - if a package is garbage, don't try to save it with FixByInstall
+ * apt-pkg/init.cc:
+ - silently ignore *.orig and *.save files by default
+ * apt-pkg/policy.cc:
+ - accept generic release pin expressions again in -t (Closes: #644166)
+ * apt-pkg/deb/debmetaindex.cc:
+ - none is a separator, not a language: no need for Index (Closes: #624218)
+ * apt-pkg/aptconfiguration.cc:
+ - do not builtin languages only if none is forced (Closes: #643787)
+ * doc/apt.conf.5.xml:
+ - apply spelling fix by Kevin Lyda, thanks! (Closes: #644104)
+
+ [ Christian Perrier ]
+ * Fix spelling error (sensée) in French translation. Thanks
+ to Corentin Le Gall for spotting it.
+
+ [ Colin Watson ]
+ * ftparchive/cachedb.cc:
+ - fix buffersize in bytes2hex
+
+ [ Michael Vogt ]
+ * ftparchive/cachedb.cc:
+ - make buffer fully dynamic (thanks to Colin Watson)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 14 Oct 2011 12:00:09 +0200
+
+apt (0.8.15.8) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * cmdline/apt-get.cc:
+ - output list of virtual package providers to c1out in -q=1
+ instead of /dev/null to unbreak sbuild (LP: #816155)
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/configuration.cc:
+ - fix double delete (LP: #848907)
+ - ignore only the invalid regexp instead of all options
+
+ -- Michael Vogt <mvo@debian.org> Wed, 14 Sep 2011 12:08:25 +0200
+
+apt (0.8.15.7) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/packagemanager.cc, apt-pkg/pkgcache.cc:
+ - ignore "self"-conflicts for all architectures of a package
+ instead of just for the architecture of the package look at
+ in the ordering of installations, too (LP: #802901)
+ - M-A:same lockstep unpack should operate on installed
+ packages first (LP: #835625)
+ * test/*
+ - reorganize the various testcases and helper we have and
+ integrate them better into the buildsystem
+ - run the test/libapt testcases at package build-time
+ * debian/apt.symbols:
+ - add the newly added symbols since 0.8.15.3
+ * cmdline/apt-get.cc:
+ - remove the binary caches in 'apt-get clean' as it is the first
+ thing recommend by many supporters in case of APT segfaults
+ - remove the caches in 'apt-get update', too, as they will be
+ invalid in most cases anyway
+ * apt-pkg/acquire-item.cc:
+ - if no Release.gpg file is found try to verify with hashes,
+ but do not fail if a hash can't be found
+ * apt-pkg/acquire.cc:
+ - non-existing directories are by definition clean
+ * cmdline/apt-key:
+ - if command is 'add' do not error out if the specified
+ keyring doesn't exist, it will be created by gpg
+ * apt-pkg/orderlist.cc:
+ - prefer visiting packages marked for deletion in VisitProvides
+ if we are operating on a negative dependency so that we can
+ deal early with the fallout of this remove
+ * apt-pkg/indexrecords.cc:
+ - fix Acquire::Max-ValidTime option by interpreting it really
+ as seconds as specified in the manpage and not as days
+ - add an Acquire::Min-ValidTime option (Closes: #640122)
+ * doc/apt.conf.5.xml:
+ - reword Acquire::Max-ValidTime documentation to make clear
+ that it doesn't provide the new Min-ValidTime functionality
+
+ -- Michael Vogt <mvo@debian.org> Mon, 12 Sep 2011 16:38:46 +0200
+
+apt (0.8.15.6) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/fileutl.{cc,h}:
+ - add GetModificationTime() helper
+ * apt-pkg/pkgcachegen.cc:
+ - regenerate the cache if the sources.list changes to ensure
+ that changes in the ordering there will be honored by apt
+ * apt-pkg/sourcelist.{cc,h}:
+ - add pkgSourceList::GetLastModifiedTime() helper
+ * apt-pkg/pkgcachegen.{cc,h}:
+ - use ref-to-ptr semantic in NewDepends() to ensure that the
+ libapt does not segfault if the cache is remapped in between
+ (LP: #812862)
+ - fix crash when P.Arch() was used but the cache got remapped
+ * test/integration/test-hashsum-verification:
+ - add regression test for hashsum verification
+ * apt-pkg/acquire-item.cc:
+ - if no Release.gpg file is found, still load the hashes for
+ verification (closes: #636314) and add test
+
+ [ David Kalnischkies ]
+ * lots of cppcheck fixes
+
+ -- Michael Vogt <mvo@debian.org> Mon, 15 Aug 2011 09:20:35 +0200
+
+apt (0.8.15.5) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/deblistparser.cc:
+ - do not assume that the last char on a line is a \n (Closes: #633350)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 28 Jul 2011 16:49:15 +0200
+
+apt (0.8.15.4) unstable; urgency=low
+
+ [ David Miller ]
+ * apt-pkg/contrib/sha1.cc:
+ - fix illegally casts of on-stack buffer to a type requiring more
+ alignment than it has resulting in segfaults on sparc (Closes: #634696)
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/cdromutl.cc:
+ - fix escape problem when looking for the mounted devices
+ * apt-pkg/contrib/strutl.{h,cc}, test/libapt/strutil_test.cc:
+ - add new DeEscapeString() similar to DeQuoteString but
+ unescape character escapes like \0XX and \xXX (plus added
+ test)
+ * refresh po/*
+
+ -- Michael Vogt <mvo@debian.org> Tue, 26 Jul 2011 12:12:27 +0200
+
+apt (0.8.15.3) unstable; urgency=low
[ Michael Vogt ]
* apt-pkg/acquire-item.cc:
* cmdline/apt-get.cc:
- restore all important dependencies for garbage packages (LP: #806274)
- do not require unused partial dirs in 'source' (Closes: #633510)
+ - buildconflicts effect all architectures
+ - implement MultiarchCross for build-dep and source (Closes: #632221)
* apt-pkg/init.cc:
- use CndSet in pkgInitConfig (Closes: #629617)
* apt-pkg/depcache.cc:
- apply madison typofix from John Feuerstein, thanks! (Closes: #633455)
* apt-pkg/policy.cc:
- emit an error on unknown APT::Default-Release value (Closes: #407511)
+ * apt-pkg/aptconfiguration.cc:
+ - ensure that native architecture is if not specified otherwise the
+ first architecture in the Architectures vector
+ * apt-pkg/deb/deblistparser.cc:
+ - Strip only :any and :native if MultiArch should be stripped as it is
+ save to ignore them in non-MultiArch contexts but if the dependency
+ is a specific architecture (and not the native) do not strip
- -- David Kalnischkies <kalnischkies@gmail.com> Sat, 16 Jul 2011 16:43:37 +0200
+ -- Michael Vogt <mvo@debian.org> Mon, 25 Jul 2011 15:04:43 +0200
apt (0.8.15.2) unstable; urgency=high