]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
French updated by Christian Perrier
[apt.git] / debian / apt.postinst
index 6236acd426bbed4ba9d226ebf2e2a5f06f7db0f8..4d87c4e256f8ab3ee936a6037a6f0b748ef53580 100644 (file)
@@ -2,24 +2,6 @@
 
 set -e
 
-# set the proxy based on the admin users gconf settings 
-# 
-set_apt_proxy_from_gconf() {
-    admin_user=$(getent group admin|cut -d: -f4|cut -d, -f1)
-    if [ -n "$admin_user" ] && [ -x /usr/bin/sudo ] && [ -z "$http_proxy" ] && [ -x /usr/bin/gconftool ]; then
-       use=$(sudo -u "$admin_user" gconftool --get /system/http_proxy/use_http_proxy 2>/dev/null)
-       host=$(sudo -u "$admin_user" gconftool --get /system/http_proxy/host 2>/dev/null)
-       port=$(sudo -u "$admin_user" gconftool --get /system/http_proxy/port 2>/dev/null)
-       if [ "$use" = "true" ] && [ -n "$host" ] && [ -n "$port" ]; then
-           APT_CONF_PROXY=""
-           eval $(apt-config shell APT_CONF_PROXY Acquire::http::proxy)
-           if [ -z "$APT_CONF_PROXY" ]; then
-               echo "Acquire::http::proxy \"http://$host:$port/\";" >> /etc/apt/apt.conf
-           fi
-       fi
-    fi
-}
-
 # summary of how this script can be called:
 #        * <postinst> `configure' <most-recently-configured-version>
 #        * <old-postinst> `abort-upgrade' <new version>
@@ -33,16 +15,12 @@ set_apt_proxy_from_gconf() {
 
 case "$1" in
     configure)
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
-        fi
-
-       # mvo: get gconf defaults once and write to a file, reason is
-       #      that sudo no longer honors http_proxy
-       # this can be removed after lucid is released
-       if dpkg --compare-versions "$2" lt-nl "0.7.25.3ubuntu2"; then
-           set_apt_proxy_from_gconf
+       SECRING='/etc/apt/secring.gpg'
+       # test if secring is an empty normal file
+       if test -f $SECRING -a ! -s $SECRING; then
+               rm -f $SECRING
        fi
+       apt-key update
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)