]> git.saurik.com Git - apt.git/blobdiff - debian/rules
use the correct line to get the currently configure.in version
[apt.git] / debian / rules
index 00e6bd4b7e5aaa159285d4b4cd4b63375fdf8bc8..b819460c177c9d3e987ef29402677784da6ca9f6 100755 (executable)
@@ -35,7 +35,7 @@ build:
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
-APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CONFVER=$(shell sed -n -e 's/^PACKAGE_VERSION="\(.*\)"/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use