]> git.saurik.com Git - apt.git/blobdiff - debian/libapt-pkg5.0.symbols
Update symbols file
[apt.git] / debian / libapt-pkg5.0.symbols
index 021d219af3cab070868942a9dd0b1cb845ccf53f..47839217b4b6e24c3355013e12e648efd7044e5e 100644 (file)
@@ -298,7 +298,6 @@ libapt-pkg.so.5.0 libapt-pkg5.0 #MINVER#
  (c++)"Configuration::Configuration(Configuration::Item const*)@APTPKG_5.0" 0.8.0
  (c++)"Configuration::Configuration()@APTPKG_5.0" 0.8.0
  (c++)"Configuration::~Configuration()@APTPKG_5.0" 0.8.0
- (c++)"WeakPointable::~WeakPointable()@APTPKG_5.0" 0.8.0
  (c++)"debListParser::ParseDepends(char const*, char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, unsigned int&, bool const&, bool const&)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::ConvertRelation(char const*, unsigned int&)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::GetPrio(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)@APTPKG_5.0" 0.8.0
@@ -1571,3 +1570,17 @@ libapt-pkg.so.5.0 libapt-pkg5.0 #MINVER#
  (c++|regex|optional=std)"^(void |DiffInfo\* |)std::_.*@APTPKG_5.0$" 0.8.0
  (c++|regex|optional=std)"^__gnu_cxx::__[^ ]+<.*@APTPKG_5.0$" 0.8.0
  (c++|optional=std)"std::ctype<char>::do_widen(char) const@APTPKG_5.0" 1.0.3
+ (c++)"APT::Configuration::Compressor::Compressor(APT::Configuration::Compressor&&)@APTPKG_5.0" 1.2
+ (c++)"APT::Configuration::Compressor::operator=(APT::Configuration::Compressor&&)@APTPKG_5.0" 1.2
+ (c++)"debStringPackageIndex::~debStringPackageIndex()@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::debStringPackageIndex(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::Exists() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetArchitecture[abi:cxx11]() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetComponent[abi:cxx11]() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetIndexFlags() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetType() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::HasPackages() const@APTPKG_5.0" 1.2.2
+ (c++)"pkgCacheFile::AddIndexFile(pkgIndexFile*)@APTPKG_5.0" 1.2.2
+ (c++)"typeinfo for debStringPackageIndex@APTPKG_5.0" 1.2.2
+ (c++)"typeinfo name for debStringPackageIndex@APTPKG_5.0" 1.2.2
+ (c++)"vtable for debStringPackageIndex@APTPKG_5.0" 1.2.2