# Default rule
build:
-PKG=apt
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-
# Determine the build directory to use
-BASE=.
-ifdef BUILD
-BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
-else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
-endif
-BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
-BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
-override BLD := $(BUILDX)
+override BASE := .
+override BLD := $(BASE)/build
-ifeq ($(words $(BLD)),0)
-override BLD := ./build
-endif
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
# APT Programs in apt-utils
APT_UTILS=ftparchive sortpkgs extracttemplates
# libapt-pkg-doc install
#
rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
- dh_installdocs -p$@ $(BLD)/docs/design* \
- $(BLD)/docs/dpkg-tech* \
- $(BLD)/docs/files* \
- $(BLD)/docs/method* \
- doc/libapt-pkg2_to_3.txt \
- doc/style.txt \
- $(BLD)/doc/doxygen/html
+ dh_installdocs -p$@
dh_installexamples -p$@
-
+ dh_lintian -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@ -X.xhtml
# apt-doc install
#
# Copy the guides
- dh_installdocs -p$@ $(BLD)/docs/guide*.text \
- $(BLD)/docs/guide*.html \
- $(BLD)/docs/offline*.text \
- $(BLD)/docs/offline*.html
+ dh_installdocs -p$@
dh_installchangelogs -p$@
dh_compress -p$@
dh_fixperms -p$@
# Remove the bits that are in apt-utils
rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
+ cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
# https has its own package
rm debian/$@/usr/lib/apt/methods/https
# debian/$@/usr/lib/apt/apt-report-mirror-failure \
# move the apt-helper in place
- mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+ mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+ # install apt.systemd.daily helper in the right place
+ install -m755 debian/apt.systemd.daily debian/$@/usr/lib/apt/
dh_bugfiles -p$@
dh_lintian -p$@
- dh_installexamples -p$@ $(BLD)/docs/examples/*
+ dh_installexamples -p$@
dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
- dh_installcron -p$@
+ dh_installcron -p$@ --name=apt-compat
+ dh_systemd_enable -p$@ apt-daily.timer
+ dh_systemd_start -p$@ apt-daily.timer
dh_installdocs -p$@
dh_installchangelogs -p$@
dh_installlogrotate -p$@
dh_installdirs -p$@
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
- cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
dh_install -p$@ --sourcedir=$(BLD)
dh_fixperms -p$@
dh_makeshlibs -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@
+ dh_shlibdeps -p$@
dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
dh_installdirs -p$@
dh_install -p$@ --sourcedir=$(BLD)
- dh_installdocs -p$@ debian/apt-transport-https.README
+ dh_installdocs -p$@
dh_installexamples -p$@
# Install the man pages..
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@
+ dh_shlibdeps -p$@
dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@