]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* Apply patch to avoid truncating of arbitrary files. Thanks to Bryan
[apt.git] / debian / rules
index b64efa92536b607cf7b116cb130eb13cd31327fe..4f6d72e062fa935424357fd920c4bfa906d9ac1d 100755 (executable)
@@ -214,6 +214,7 @@ apt: build debian/shlibs.local
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
        cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+       sed 's/^_//' share/apt-auth-failure.note > debian/$@/usr/share/$@/apt-auth-failure.note
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
        cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
 #      head -n 500 ChangeLog > debian/ChangeLog
@@ -299,7 +300,7 @@ apt-utils: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-transport-https: build debian/shlibs.local
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k