-apt (0.7.23) unstable; urgency=low
+apt (0.7.22.3) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * cmdline/apt-get.cc:
+ - add APT::Get::HideAutoRemove=small to display only a short line
+ instead of the full package list. (Closes: #537450)
+ - ShowBroken() in build-dep (by Mike O'Connor, Closes: #145916)
+ - check for statfs.f_type (by Robert Millan, Closes: #509313)
+ - correct the order of picked package binary vs source in source
+ - use SourceVersion instead of the BinaryVersion to get the source
+ Patch by Matt Kraai, thanks! (Closes: #382826)
+ - add pkg/archive and codename in source (Closes: #414105, #441178)
+ * apt-pkg/contrib/strutl.cc:
+ - enable thousand separator according to the current locale
+ (by Luca Bruno, Closes: #223712)
+ * doc/apt.conf.5.xml:
+ - mention the apt.conf.d dir (by Vincent McIntyre, Closes: #520831)
+ * apt-inst/contrib/arfile.cc:
+ - use sizeof instead strlen (by Marius Vollmer, Closes: #504325)
+ * doc/apt-mark.8.xml:
+ - improve manpage based on patch by Carl Chenet (Closes: #510286)
+ * apt-pkg/acquire-item.cc:
+ - use configsettings for dynamic compression type use and order.
+ Based on a patch by Jyrki Muukkonen, thanks! (LP: #71746)
+ * apt-pkg/init.cc:
+ - add default configuration for compression types and add lzma
+ support. Order is now bzip2, lzma, gzip, none (Closes: #510526)
+ * ftparchive/writer.cc:
+ - add lzma support also here, patch for this (and inspiration for
+ the one above) by Robert Millan, thanks!
+ * apt-pkg/depcache.cc:
+ - restore the --ignore-hold effect in the Is{Delete,Install}Ok hooks
+ * doc/apt-get.8.xml:
+ - update the source description to reflect what it actually does
+ and how it can be used. (Closes: #413021)
+ * methods/http.cc:
+ - allow empty Reason-Phase in Status-Line to please squid,
+ thanks Modestas Vainius for noticing! (Closes: #531157, LP: #411435)
+ * doc/Doxyfile.in:
+ - update file with doxygen 1.6.1 (current unstable)
+ - activate DOT_MULTI_TARGETS, it is default on since doxygen 1.5.9
+ * buildlib/po4a_manpage.mak, doc/makefile, configure:
+ - simplify the makefiles needed for po4a manpages
+
+ [ George Danchev ]
+ * cmdline/apt-cache.cc:
+ - fix a memory leak in the xvcg method (Closes: #511557)
+ * apt-pkg/indexcopy.cc:
+ - fix a memory leak then the Release file not exists (Closes: #511556)
+
+ [ Nicolas François ]
+ * Cleaned up the first patch draft from KURASAWA Nozomu to finally
+ get po4a support for translating the man pages.
+ Many thanks to both for this excellent work! (Closes: #441608)
+ * doc/ja/*, doc/po/ja.po:
+ - remove the old ja man page translation and replace it with
+ the new po4a-powered translation by KURASAWA Nozomu.
+ * doc/*.?.xml (manpages):
+ - add contrib to author tags and also add refmiscinfo to fix warnings
+ * doc/style.txt, buildlib/defaults.mak, buildlib/manpage.mak:
+ - fix a few typos in the comments of this files
+
+ -- David Kalnischkies <david@kalnischkies.com> Sat, 08 Aug 2009 09:40:08 +0200
+
+apt (0.7.22.2) unstable; urgency=low
+
+ * debian/apt.cron.daily:
+ - Make sure that VERBOSE is always set (Closes: #539366)
+ - Script can be disabled by APT::Periodic::Enable=0 (Closes: #485476)
+ - Support using debdelta to download packages (Closes: #532079)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 06 Aug 2009 12:17:19 +0200
+
+apt (0.7.22.1) unstable; urgency=low
[ Michael Vogt ]
* cmdline/apt-get.cc:
- honor APT::Get::Only-Source properly in FindSrc() (thanks to
- Martin Pitt for reporting the problem)
+ Martin Pitt for reporting the problem), also Closes: #535362.
[ Julian Andres Klode ]
* apt-pkg/contrib/mmap.cc:
- Fix FTBFS on GNU/kFreeBSD by disabling DynamicMMap::Grow() on
- non-Linux architectures (as it uses mremap).
+ non-Linux architectures as it uses mremap (Closes: #539742).
* apt-pkg/sourcelist.cc:
- Only warn about missing sources.list if there is no sources.list.d
and vice versa as only one of them is needed (Closes: #539731).
* debian/control:
- Add myself to Uploaders.
+ - Increase Standards-Version to 3.8.2.0.
-- Julian Andres Klode <jak@debian.org> Mon, 03 Aug 2009 12:48:31 +0200
(off by default)
- send "dpkg-exec" message on the status fd when dpkg is run
- provide DPkg::Chroot-Directory config option (useful for testing)
- - fix potential hang when in a backgroud process group
+ - fix potential hang when in a background process group
* apt-pkg/algorithms.cc:
- consider recommends when making the scores for the problem
resolver
* apt-pkg/deb/debsystem.cc:
- make strings i18n able
* fix problematic use of tolower() when calculating the version
- hash by using locale independant tolower_ascii() function.
+ hash by using locale independent tolower_ascii() function.
Thanks to M. Vefa Bicakci (LP: #80248)
* build fixes for g++-4.4
* cmdline/apt-mark: