+apt (0.5.5) unstable; urgency=low
+
+ * New deb version compare function, that has no integer limits, and
+ supports pre-versions using ~. Code ported from dpkg.
+ * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
+ * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
+ * "apt-get --arch-only build-dep" to install only architecture-
+ dependent build dependencies. Bump minor shared lib number to reflect
+ small change in BuildDepend API.
+ * APT::Build-Essential configuration option (defaults to "build-essential")
+ so that "apt-get build-dep" will ensure build essential packages are
+ installed prior to installing other build-dependencies. Closes: #148879
+ * LD_LIBRARY_PATH thing. Closes: #109430, #147529
+ * /usr/doc reference in postinst. Closes: #126189
+ * Doc updates. Closes: #120689
+ * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
+ #131062, #136749
+ * Print special message for EAI_AGAIN. Closes: #131397
+ * libapt-pkg-dev needs to bring in the apt-inst library if linking
+ is to work. Closes: #133943
+ * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
+ #109591, #105920, #103678, #139752, #138186, #138054, #138050,
+ #139994, #142955, #151654, #151834, #147611, #154268
+ * Fix possibility for tag file parsing to fail in some unlikely situations.
+ Closes: #139328
+ * Use std C++ names for some header files. Closes: #128741,
+ * Do not check for free space if --no-download. Closes: #117856
+ * Actually implement or group handling for 'upgrade'. Closes: #133950
+ * "Internal Error, Couldn't configure pre-depend" is not actually an
+ internal error, it is a packaging error and now it says so, and
+ pinpoints the problem dependency. Closes: #155621
+ * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
+ * Use usr/share/doc for dhelp. Closes: #115701
+ * --print-uris works with 'update'. Closes: #57070
+ * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
+ command line.
+ * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
+ #142298
+ * Allow an uninstalled package to be marked for removal on an install
+ line (meaning not to automatically install it), also fix some dodgy
+ handling of protected packages. Closes: #92287, #116011
+ * Fix errant prefix matching in version selection. Closes: #105968
+ * Ensure that all files needed to run APT as a user are readable and
+ ignore roots umask for these files. Closes: #108801
+ * Support larger config spaces. Closes: #111914
+ * 'apt-get update' no longer does 'Building Dependency Tree'.
+ * When matching regexs allways print a message. Change regex activation
+ charset. Closes: #147817
+ * Don't die if lines in sources.list are too long. Closes: #146846
+ * Show file name on apt-extracttemplate error messges. Closes: #151835
+ * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
+ * Some highly unlikely memory faults. Closes: #155842
+ * C++ stuff for G++3.2. Closes: #162617, #165515,
+ * apt-config dumps sends to stdout not stderr now. Closes: #146294
+ * Fix segfault in FindAny when /i is used, and there is no default.
+ Closes: #165891
+ * Add s390x to archtable. Closese: #160992.
+ * Update config.sub/config.guess in cvs, and add support to debian/rules
+ to update them from /usr/share/misc if they exist. Closes: #155014
+ * Remove 'Sorry' from messages. Closes: #148824.
+ * Change wording of 'additional disk space usage' message. Closes:
+ #135021.
+ * apt-extracttemplates now prepends the package name when extracting
+ files. Closes: #132776
+ * Add -n synonym for --names-only for apt-cache. Closes: #130689
+ * Display both current version and new version in apt-get -s. Closes:
+ #92358
+ * Add an options and timeout config item to ssh/rsh. Closes: #90654
+ * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
+ * Change verbose logging output of apt-ftparchive to go to stderr,
+ instead of stdout. Also, errors that occur no longer go to stdout,
+ but stderr. Closes: #161592
+ * Test for timegm in configure. Closes: #165516.
+ * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
+ support compliation on platforms where st_mtime is a macro. Closes:
+ #165518
+ * Check the currently mounted cdrom, to see if it's the one we are
+ interested in. Closes: #154602
+ * Rebuild with gcc-3.2. Closes: #177752, #178008.
+ * Fix build-dep handling of | dependencies.
+ Closes: #98640, #145997, #158896, #172901
+ * Double default value of APT::Cache-Limit, until such time as it
+ can be made more dynamic. Closes: #178623.
+ * Report uris with '.gz' when there are errors. Closes: #178435.
+ * When installing build-deps, make sure the new version will
+ satisfy build requirements. Closes: #178121
+
+ -- Jason Gunthorpe <jgg@debian.org> Sun, 15 Sep 2002 17:16:59 -0600
+
apt (0.5.4) unstable; urgency=low
* M68k config.guess patch. Closes: #88913
* Bi-yearly test on OpenBSD and Solaris
- * Doc updates. Closes: #89121, #89854
+ * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
+ #97520, #102867, #101071, #102421, #101565, #98272, #106914,
+ #105606, #105377
* Various cosmetic code updates. Closes: #89066, #89066, #89152
* Add "pre-auto" as an option for DSelect::Clean (run autoclean after
update).
similar situations. Closes: #56708, #59432
* no_proxy and ftp. Closes: #89671
* Philippe Batailler's man page patches.
- * Fix for display bug. Closes: #92033
+ * Fix for display bug. Closes: #92033, #93652, #98468
+ * Use more than 16bits for the dep ID. Some people ran out..
+ Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
+ #106911, #107395, #108968
* Reordered some things to make dante and FTP happier. Closes: #92757
* James R. Van Zandt's guide.sgml updates. Closes: #90027
* apt-ftparchive copes with no uncompressed package files + contents.
* Fixed no_proxy tokanizing. Closes: #100046
* Strip Config-Version when copying status to available. Closes: #97520
* Segfault with missing source files. Closes: #100325
+ * EINTR check. Closes: #102293
+ * Various changes to the locking metholodgy for --print-uris.
+ Closes: #100590
+ * Lame LD_LIBRARY_PATH thing. Closes: #98928
+ * apt-cache search searchs provide names too now. Closes: #98695
+ * Checksum and long lines problem. Closes: #106591
+ * .aptignr and empty files are just a warning. Closes: #97364
- -- Jason Gunthorpe <jgg@debian.org> Thu, 8 Mar 2001 22:48:06 -0700
+ -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
apt (0.5.3) unstable; urgency=low
-- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
-Local variables:
-mode: debian-changelog
-add-log-mailing-address: "che@debian.org"
-End: