- let pkgCache::Iterator inherent std::iterator
* apt-pkg/depcache.cc:
- correct "Dangerous iterator usage." pointed out by cppcheck
+ * ftparchive/writer.h:
+ - add a virtual destructor to FTWScanner class (for cppcheck)
+ * apt-pkg/cacheset.{cc,h}:
+ - add simple wrapper around std::set for cache structures
+ - move regex magic from apt-get to new FromRegEx method
+ - move cmdline parsing from apt-cache to new FromCommandLine method
+ * apt-pkg/contrib/cmdline.cc:
+ - fix segfault in SaveInConfig caused by writing over char[] sizes
+ * apt-pkg/pkgcache.cc:
+ - get the best matching arch package from a group with FindPreferredPkg
+ * cmdline/apt-cache.cc:
+ - make the search multiarch compatible by using GrpIterator instead
+ * apt-pkg/cachefile.{cc,h}:
+ - split Open() into submethods to be able to build only parts
+ - make the OpProgress optional in the Cache buildprocess
+ - store also the SourceList we use internally for export
- -- David Kalnischkies <kalnischkies@gmail.com> Sat, 29 May 2010 19:02:12 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Mon, 31 May 2010 22:36:35 +0200
apt (0.7.26~exp5) experimental; urgency=low