+apt (1.4~beta1) unstable; urgency=medium
+
+ [ Chris Leick ]
+ * Updated German documentation translation
+ * fix three typos in sources & manpages
+ * German translation proof read by Helge Kreutzmann
+
+ [ Frans Spiesschaert ]
+ * Dutch program translation update (Closes: #840552)
+ * Dutch manpages translation update (Closes: #840757)
+
+ [ David Kalnischkies ]
+ * don't install new deps of candidates for kept back pkgs
+ * keep Release.gpg on untrusted to trusted IMS-Hit (Closes: 838779)
+ * fix testcase expecting incorrect remove log from dpkg
+ * reset HOME, USER(NAME), TMPDIR & SHELL in DropPrivileges (Closes: 842877)
+ * show the conflicting distribution warning again (Closes: 841874)
+ * rename Checksum-FileSize to Filesize in hashsum mismatch
+ * improve SOCKS error messages for http slightly
+ * support 'apt build-dep .' (aka: without /)
+ * add TMP/TEMP/TEMPDIR to the TMPDIR DropPrivileges dance
+ * http: skip connection cleanup if we close it anyhow
+ * add hidden config to set packages as Essential/Important.
+ Thanks to Anthony Towns for initial patch (Closes: 767891)
+ * don't warn if untransformed distribution matches.
+ Thanks to Lukas Anzinger for initial patch (Closes: 644610)
+ * show distribution mismatch for changed codenames
+ * react to trig-pend only if we have nothing else to do
+ * correct cross & disappear progress detection
+ * improve arch-unqualified dpkg-progress parsing
+ * don't perform implicit crossgrades involving M-A:same
+ * do not configure unconfigured to be removed packages
+ * skip unconfigure for unconfigured to-be removed pkgs
+ * report apt-key errors via status-fd messages (LP: #1522988)
+ * add apt-key support for armored GPG key files (*.asc)
+ * document which keyring formats are supported by apt-key (Closes: 844724)
+ * get pdiff files from the same mirror as the index
+ * follow the googletest merge in build-depends
+
+ [ Michael Vogt ]
+ * Do not (re)start "apt-daily.system"
+ Thanks to Alexandre Detiste (Closes: #841763)
+
+ [ Johannes Schauer ]
+ * add support for Build-Depends/Conflicts-Arch (Closes: #837395)
+
+ [ Edgar Fuß ]
+ * http: clear content before reporting the failure (Closes: #465572)
+
+ [ James Clarke ]
+ * apt-ftparchive: Support NotAutomatic and ButAutomaticUpgrades fields
+ (Closes: #272557)
+
+ [ Julian Andres Klode ]
+ * TagSection: Split AlphaIndexes into AlphaIndexes and BetaIndexes
+ * TagSection: Extract Find() methods taking Pos instead of Key
+ * Squashed 'triehash/' content from commit 16f59e1
+ * TagSection: Introduce functions for looking up by key ids
+ * debListParser: Convert to use pkgTagSection::Key-based lookup
+ * Bump the cache major version for non-backportable changes
+ * Introduce tolower_ascii_unsafe() and use it for hashing
+ * Optimize VersionHash() to not need temporary copy of input
+ * Compare size before data when ordering cache bucket entries
+ * debListParser: Micro-optimize AvailableDescriptionLanguages()
+ * Do not use MD5SumValue for Description_md5()
+ * gpgv: Untrust SHA1, RIPE-MD/160, but allow downgrading to weak
+
+ [ Paul Wise ]
+ * show output as documented for APT::Periodic::Verbose 2 (Closes: 845599)
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 25 Nov 2016 23:49:54 +0100
+
+apt (1.3.1) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Do not read stderr from proxy autodetection scripts
+ * travis: Move codecov from after_success to after_script
+
+ [ victory ]
+ * Japanese manpages translation update
+
+ [ Mert Dirik ]
+ * Turkish program translation update (Closes: #838731)
+
+ -- Julian Andres Klode <jak@debian.org> Tue, 04 Oct 2016 19:43:35 +0200
+
+apt (1.3) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * abort connection on '.' target replies in SRV
+ * edsp: try 2 to read responses even if writing failed
+
+ [ Julian Andres Klode ]
+ * test: Always install dpkg into our tests, regardless of MA
+ * CMake: Add coverage build type
+ * Coverage: Do not print messages from gcov
+ * VersionHash: Do not skip too long dependency lines
+
+ -- Julian Andres Klode <jak@debian.org> Tue, 20 Sep 2016 23:53:51 +0200
+
+apt (1.3~rc4) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Fix segfault and out-of-bounds read in Binary fields
+ * TagFile: Fix off-by-one errors in comment stripping
+ * Base256ToNum: Fix uninitialized value
+ * test-apt-cdrom: Fix for gnupg 2.1.15
+ * CMake: test/libapt: Use a prebuilt GTest library if available
+ * CMake: apt-pkg: Use correct ICONV_INCLUDE_DIRS variable
+ * acquire: Use priority queues and a 3 stage pipeline design
+ => faster updates with better progress reporting
+ * debian: Move bugscript to old location for overlayfs xdev issue
+ * debian: Pass -O to make to get readable build logs
+
+ [ David Kalnischkies ]
+ * try not to call memcpy with length 0 in hash calculations
+ * re-add apt breaks/replaces apt-utils (<< 1.3~exp2~) (Closes: #836220)
+ * support long keyid and fingerprint in gpgv's GOODSIG
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 02 Sep 2016 20:26:36 +0200
+
+apt (1.3~rc3) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Ignore SIGINT and SIGQUIT for Pre-Install hooks
+ This basically fixes Bug #832593, as long as your /bin/sh
+ is not dash, as dash is evil.
+ * prepare-release: Use equivs and gdebi-core for travis deps
+ * install-progress: Call the real ::fork() in our fork() method
+ * Packaging cleanup:
+ - debian: Install etc/apt if present (e.g., on Ubuntu)
+ - tests/control: Handle the gpg1/gpg2 mess a bit better
+ - debian: Make better use of the tree installed by CMake
+ - debian: Switch to debhelper 10
+ - debian: Add more lintian overrides
+ - debian: Drop outdated stuff
+ - debian: Run wrap-and-sort
+ - Add new symbols to symbols file
+ * Build system fixes, including:
+ - CMake: Translations: Don't rebuild .mo for line number changes
+ - CMake: Translations: Pass --previous to msgmerge.
+ Thanks to Guillem Jover for the suggestion.
+ - CMake: Do not add po/ if USE_NLS is OFF
+ - CMake: Install config and logging directories
+ - CMake: Translations: Build byproduct before output
+ - CMake: Add Large File Support (Closes: #834767)
+ * Several portability fixes (full test suite passes on FreeBSD), including:
+ - CMake: Discover docbook stylesheet in other locations
+ - Add missing includes and external definitions
+ - Use C locale instead of C.UTF-8 for protocol strings
+ - Make directory paths configurable
+ - Lower-case uname -r output in kernel autoremove helper
+ - Make root group configurable via ROOT_GROUP
+ * Accept --autoremove as alias for --auto-remove
+ * apt-inst: debfile: Pass comp. Name to ExtractTar, not Binary
+ * changelog: Respect Dir setting for local changelog getting
+ * init: Add Dir::Bin::planners default entry
+ * Switch documentation from httpredir.d.o to deb.d.o
+
+ [ Zhou Mo ]
+ * zh_CN.po: update simplified Chinese translation
+
+ [ David Kalnischkies ]
+ * do dpkg --configure before --remove/--purge --pending (Closes: 835094)
+ * prevent C++ locale number formatting in text APIs (try 3) (LP: 1611010)
+ * do fail on weakhash/loop earlier in acquire (Closes: 835195)
+ * do not restore selections for already purged packages
+ * apt-key: warn instead of fail on unreadable keyrings
+ * show apt-key warnings in apt update (Closes: 834973)
+ * treat .ddeb files like .deb, especially for dpkg (LP: #1616909)
+ * randomize acquire order for same type index files
+ * don't loop on pinning pkgs from absolute debs by regex (Closes: 835818)
+
+ -- Julian Andres Klode <jak@debian.org> Tue, 30 Aug 2016 22:20:28 +0200
+
apt (1.3~rc2) unstable; urgency=medium
[ Julian Andres Klode ]
* Fix select timeout to be 50msec instead of 0.5msec (Closes: #799857)
[ David Kalnischkies ]
- * M-A: allowed pkgs of unconfigured archs do not statisfy :any
+ * M-A: allowed pkgs of unconfigured archs do not satisfy :any
* implement dpkgs vision of interpreting pkg:<arch> dependencies
* add Source-Version field for EDSP
* fix insecure use of /tmp in EDSP solver 'dump' (Closes: 795600)
- handle :all and :native correctly as architectures again
in the commandline parsing (regression in 0.9.7)
* apt-pkg/packagemanager.cc:
- - do not segfault if nothing can be configured to statisfy
+ - do not segfault if nothing can be configured to satisfy
a pre-depends (e.g. in a pre-depends loop) (Closes: #681958)
* apt-pkg/contrib/mmap.cc:
- trigger the usage of the fallback code for kfreebsd also in the
- load the dpkg base arguments only one time and reuse them later
* cmdline/apt-get.cc:
- follow Provides in the evaluation of saving candidates, too, for
- statisfying garbage package dependencies (Closes: #640590)
+ satisfying garbage package dependencies (Closes: #640590)
* apt-pkg/algorithms.cc:
- if a package is garbage, don't try to save it with FixByInstall
* apt-pkg/deb/debsrcrecords.cc:
- load the dpkg base arguments only one time and reuse them later
* cmdline/apt-get.cc:
- follow Provides in the evaluation of saving candidates, too, for
- statisfying garbage package dependencies (Closes: #640590)
+ satisfying garbage package dependencies (Closes: #640590)
* apt-pkg/algorithms.cc:
- if a package is garbage, don't try to save it with FixByInstall
* apt-pkg/init.cc:
consider it as a candidate for FixByInstall
* apt-pkg/depcache.cc:
- don't install previously not installed providers in a try
- to statisfy a "Breaks: provides" dependency by upgrade
+ to satisfy a "Breaks: provides" dependency by upgrade
* cmdline/acqprogress.cc:
- don't ask the user for media change if quiet >= 2, stdout is not
a tty and assume-yes, force-yes or trivial-only option is set to