]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* Use cvs update -d in debian/rules cvs-build rather th...
[apt.git] / debian / rules
index 3361f0e1fdeb3974cf8fa63151370a684c33c475..b5c848aa2f2e2fce30feded1fb857d818e9329e2 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.45 2003/02/02 22:00:24 doogie Exp $
+# $Id: rules,v 1.56 2003/12/21 00:07:35 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -14,8 +14,6 @@
 # create ../upload-<VER>, with all the files needed to be uploaded placed
 # in it.
 
-export DH_COMPAT=2
-
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
@@ -88,6 +86,7 @@ debian/shlibs.local: apt-pkg/makefile
        echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
 
 build: build/build-stamp       
+build-doc: build/build-doc-stamp       
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -100,20 +99,17 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-ifneq ($(wildcard /usr/share/misc/config.sub),)
-       cp -a /usr/share/misc/config.sub buildlib/config.sub
-       echo Updating buildlib/config.sub
-endif
-ifneq ($(wildcard /usr/share/misc/config.guess),)
-       cp -a /usr/share/misc/config.guess buildlib/config.guess
-       echo Updating buildlib/config.guess
-endif
        cd build && ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) -s
+       $(MAKE) binary
+       touch $@
+
+build/build-doc-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) doc
        touch $@
 
 clean:
@@ -127,9 +123,9 @@ clean:
        # Add here commands to clean up after the build process.
        dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
 
-binary-indep: libapt-pkg-doc
+binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build debian/shlibs.local
+libapt-pkg-doc: build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -140,15 +136,11 @@ libapt-pkg-doc: build debian/shlibs.local
        dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
                             $(BLD)/docs/files* $(BLD)/docs/method* \
                            doc/libapt-pkg2_to_3.txt doc/style.txt
-
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
-
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
 #      dh_undocumented -p$@
        dh_installchangelogs -p$@
@@ -161,6 +153,25 @@ libapt-pkg-doc: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-doc: build-doc
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+#
+# apt-doc install
+#
+       # Copy the guides
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
+                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+       dh_installchangelogs -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+
 
 # Build architecture-dependent files here.
 
@@ -169,7 +180,7 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share
+       dh_installdirs -p$@ /usr/share/bug/$@
 #
 # apt install
 #
@@ -187,27 +198,22 @@ apt: build debian/shlibs.local
        cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/apt/usr/share/
 
-       # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
-
-       # One or the other..
-       -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
-       -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
+       cp debian/bugscript debian/apt/usr/share/bug/apt/script
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
+       dh_installman -p$@ 
 
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
        dh_installdeb -p$@
        dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
-       dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -228,7 +234,7 @@ libapt-pkg-dev: build debian/shlibs.local
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -254,17 +260,16 @@ apt-utils: build debian/shlibs.local
        dh_installdocs -p$@
 
        # Install the man pages..
-       mkdir -p debian/$@/usr/share/man/man1
-       -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
+       dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_installdeb -p$@
        LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
-       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -303,10 +308,10 @@ binary: binary-indep binary-arch
 
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update
+       cvs update -d
        $(MAKE) startup
        $(MAKE) doc
-       tar c --exclude CVS --exclude cvs-build . |\
+       tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
                (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
        (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))